disc drive not working in lenovo all-in-one

  ali-h 14:10 01 Jul 2012

hi I have a two month old allin-one. I tried running cd/dvd but nothing happens. The auto play in control panel is ticked. I switched off the computer several times but no joy.

Can anyone please help


  Ian in Northampton 15:28 01 Jul 2012

An obvious question, but it has to be asked... Have you tried different CDs/DVDs, and still experienced the same problem?

  lotvic 15:47 01 Jul 2012

In Windows Explorer, does it show that there is a cd/dvd in and it's contents?

  Fruit Bat /\0/\ 18:49 01 Jul 2012

two month old allin-one

therefore it should be under guarantee so may not be worth physically fiddling with.

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41 Try this if the optical drives are not appearing in My Computer or Device Manager. (This is sometimes caused by the removal of Roxio or other writing software.)

http://www.dougknox.com/xp/utils/XP_CD-DVD-Fix.zip Download XP_CD-DVD-Fix.zip and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect. This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7. You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes http://support.microsoft.com/kb/314060/ works for W7 Vista or XP http://aumha.org/downloads/cdgone.zip

or manual fix Run regedit and navigate to registry key HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If in doubt make a restore point before making changes.

  ali-h 07:59 02 Jul 2012

Many thanks guys for your help. I managed to sort it out last night. It was a long drawn out issue and I have to go out for the day in awhile.

I shall post later this evening what I did.


  ali-h 09:02 06 Jul 2012

Hi The problem with my computer seems to be intermittent. I took it back to the original factory settings and it still played me up so I decided to send it back to Amazon. Hopefully the carrier will collect it today.

Thanks again for your suggestions


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?