Disable LogOn Password/Click W7

  Furkin 09:29 02 Sep 2011

Asus M4A78LT-M LE + Phenom IIx2 + 4Gb RAM + Win 7.

When I first rebuilt this kit, I set it up as NO log-on password needed.
A couple of months ago, I needed something which needed Admin rights, so I used them. Ever since then, upon boot up, the machine stops and up pops 2 two icons on the screen. One is Admin & the other is My Name Admin. I don’t have to physically put in a password, merely click on My Name Admin. My routine is/was that in the morning, I turn the machine on then make a cup of tea. I like the machine to be on, running, updated & warmed up when I come to use it. Of course in its current state, it stops halfway – so I want to disable the password/Click on.

I Google’d for a method to stop it, & saw someone’s thread saying: "go to run > userpasswords2" etc - which I followed. After un-ticking the appropriate box - when it was rebooting, it invited me to upgrade from IE8 to IE9. So far, this machine won't take IE9 - don't know why (see specific post - please).
As the invitation was there, I clicked 'Yes'. As usual, it came up with "wasn't installed". No great surprise there.

When Windows was opening up, I was pleased to see that the log-on Pass/Click icons were now gone, but so was the Wallpaper/Screen theme. I just thought I’ll re-do it when it’s booted.

When Google came up, I saw that I’d lost all my Favourites ! This was no good, so I decided to Restore a few hours. When I went to restore, the last Point I had was 28th Aug, so I had to use it.

System restored – but so were the log-on icons.

I was hoping that the loss of Favourites was due to trying to upgrade IE, so was looking for “Run > userpasswords2" again to re disable log-on bits again. But it seems that now, I don’t have userpasswords2 any more ! It doesn’t pop up in Run or Search – so I can’t use that method.

Q1/ Did my Fave’s disappear because I was trying the IE update ? I’ve tried this update a dozen times & it’s never done that before.

Q2/ Did my Fave’s disappear because I disabled the Log-on routine ? I didn’t expect that,,,, but nor did I expect it to lose the Wallpaper/Screen theme.

Q3/ Can I re install “userpasswords2" for future use ?

Q4/ Is there another way to disable log-on pass/click ?

Q4a/ Whilst my laptop does boot up o.k, when it comes out of it’s slumber, I have to click on its log-on icon as well – though there is only a choice of one – My Name.

Q5/ Because my machine won’t take IE9, is it likely that it won’t take IE10 when it comes out ? It has taken W SP1.

thanks for reading

  rawprawn 09:34 02 Sep 2011

Have you looked in msconfig / boot tab to see if there are two boots listed ? If so delete the one you don' want. I don' know if this is the answer but it' worth a look.

  rawprawn 09:43 02 Sep 2011

Or, User Accounts and delete My Name Admin

  northumbria61 10:16 02 Sep 2011

There's no logical reason why your computer shouldn't be able to upgrade to IE9 - make sure you have all the latest Windows Updates first then try downloading from Windows Catalog.

If you have another browser installed and can use then try uninstalling IE8 (although it is part of Windows 7 it can still be done - see LINK) and then install IE9

enter link [enter link description heredescription here]1

OR read below for uninstall/reinstall IE8

Go to Control Panel\Programs and Features\Turn Windows features on or off. Uncheck Internet Explorer 8, click OK and reboot. You will not have Internet Explorer installed then. Go to Windows features again and check Internet Explorer 8, reboot. Now you will have Internet Explorer installed again.

  Furkin 11:06 02 Sep 2011

Hi RP: Ah,,,,,

Am I now right in assuming that it isn't actually asking for a password,,,, it's only asking which account I want to open with,,, cos there are two ?

I used to use My Name Admin all the time untill I needed the Admin one. I would prefer to stick with that.
In User accounts > manage another account I see 3 accounts.

1/ Admin

2/ My Name Admin

3/ Guest = Guest Account is Off.

It also says to only use Admin when actually needed.

If I disable Admin in User Accounts, will it still be there, but unusable,,, or will it be deleted ?


Can I get “userpasswords2" back ?


Thanks also N61:

The rest of the updates are taken as soon as they are available. The odd thing is: My Desktop will take the SP1 update - but not the IE9. My Lappy will take the IE9 update - but not the SP1 ?

Both running Windows 7, 4Gb ram, plenty of room etc.

I also need to make sure that I don't lose my Faves.

Will look into this bit when the log-on stuff sorted.


regards to you both

  rawprawn 11:58 02 Sep 2011

Just disable it, you can make accounts any name you want.

  sheraz.civnom 12:24 02 Sep 2011

you need to disable UAC in Control Panel and try to update your computer using Windows Update. Hope this will solve you problem.

  sheraz.civnom 12:24 02 Sep 2011

you need to disable UAC in Control Panel and try to update your computer using Windows Update. Hope this will solve you problem.

  Furkin 13:08 02 Sep 2011


When running as My Name Admin all is well, apart from boot-up niggle. I can't delete/disable Admin.

I re booted as Admin to see if I could alter things from there. Still can't disable Admin. Also, when in Admin, I lose my Google Faves again,,,, & I'm guessing other stuff too.

Gone back to My Name Admin & all is well again, apart from boot-up niggle.

Hospital awaits, so will catch up with you later.


Sheraz: Been trying to update IE since v9 first came out, using W update, Auto update, Manual update etc - all to noah vail.

see above re User Accounts

thanks for your help.

  rawprawn 16:31 02 Sep 2011

Run a system file check, open the Command Prompt by right clicking and select "Run as Administrator" at the C: propmt type sfc /scannow and hit Enter. it will take a while to run. Please note the space between sfc and /scannow

  Furkin 23:20 02 Sep 2011

Booted up as My Name Admin and ran scannow. It said that there are some corrupt files that can't be fixed, & that a log will be made. I couldn’t find the log.

I re booted as Admin and tried to run scannow again. At Dos prompt I was denied access, so I rebooted in My Name Admin, ran scan again.

In search I did find the Log folder, but have no idea where to look, or what the scan has done or might have told me.

Will it help you to help me ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)