direct x 9 problem

  [DELETED] 07:11 20 Dec 2003

Up until yesterday evening it was working fine...then when i tried to play Halo(which is a dx9 game) i got the message that it couldn't initialise direct draw....ran dxdiag and all tabs say no problems,however direct draw acceleration and agp texture acceleration are showing as not available,so i know what the problem is,don't know how to fix it tho.So far i've reinstalled the graphics card drivers,DX9 and the chipset drivers....all to no avail.I'm running windows XP home with SP1,and a Radeon 9800 Pro graphics card with the latest catalyst drivers.Tried a system restore as well but it wouldn't restore.

  [DELETED] 10:00 20 Dec 2003

Hello Mate,

AGP texturing will be disabled if you havn't installed your AGP port driver. This will be provided on your motherboard cd (or from your Mobo's website). I have no idea why your game is crashing - try reinstalling Halo.

  [DELETED] 11:06 20 Dec 2003

i've reinstalled the m.board chipset drivers 3 times now..all to no effect..and it isn't that halo just refuses to start with the error message about direct draw not initialising
i've looked on asus website for a seperate agp port driver but found nothing( i have an a7v333 m/board)so assume it is with the 4in1 drivers.
thanks for the advice but i think it must be something else causing this

  [DELETED] 12:18 20 Dec 2003

There are 3 different flavours of DX-9,I get alsorts of agro from DX-9b(latest) but not straight away,I use DX-9a most often,as my download of plain DX-9 has been lost.This used to work best for me,but I haven't been able to relocate the site for DX-9,a search on google for the different flavours of DX should get them.

  hugh-265156 15:27 20 Dec 2003

click start/run and type "dxdiag" click ok

click the display tab and run the tests,any errors?

you can also enable direct draw and 3d here too.

dx9 version 9b is a safer bet than 9a as all the files are final retail,in 9a there are a lot of beta files which may cause problems for some.if you need to reinstall get the redist version(you can save)click here

  Stuartli 17:50 20 Dec 2003

DirectX is free - you just download it from the Microsoft website as your link indicates.

I think you mean the final version (for the moment at least).

Microsoft did warn when DirectX was first launched that some drivers may have to be updated and that certain problems could arise.

  hugh-265156 18:03 20 Dec 2003

i know its free lol!

they are named "final retail" in dxdiag/directxfiles have a look.

  [DELETED] 18:39 20 Dec 2003

Tried 9a..exactly the same so am back to dxdiag all the tabs show no problems in the notes at the bottom,however direct draw acceleration and agp texture acceleration still show not available.I ran a test and direct draw seems to work..altho the second test with the not full screen bouncing ball seems to slow down badly at times.direct3d acceleration(which is showing as ok)however fails the first test,the dx7 one,message i get is ..test failed at step8(creating 3d device):HRESULT ox800700e(out of memory)...dx 8 and 9 test work ok tho.only other thing i've noticed is that where it gives you a breakdown of your adapter approx total memory is also showing as n/a.i've also,on the advice of evesham,done a repair of windows,used the recovery console for a chkdsk.used safe mode and removed everything related to ATi and reinstalled

  hugh-265156 18:57 20 Dec 2003

try to enable full hardware acceleration in the ati control panel/advanced/troubleshoothing tab then run tests again

  hugh-265156 18:59 20 Dec 2003

also read click here

  [DELETED] 19:05 20 Dec 2003

I had a couple of problems with this game too. I got the error messages at the start of the game claiming my graphics card was unknown (I have a Radeon 9800 Pro aswell 128MB version) and that I hadn't enough RAM (I have 1GB of pc3200. More than enough to run halo)

now my graphics card was installed properly and had everything fine yet Halo just doesn't seem to recognise it. It appears halo has problems with the 9800 Pro like not being able to display textures properly without turning them to a rainbow and such. One of these problems appears to be just not recognising it, i downloaded the update for the game and it cleared most of the problems up for me.

Having said that, i can't help with the DX9 stuff :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple