Device Manager is empty!

  davc 11:33 01 Jul 2004

My system is W2K with SP4. My device manager window is completely empty. I have looked in MS knowledge base but with no rseults.

I checked in 'Services' and the Plug and play manager is started and set to automatic. I have not been fiddling behind the scenes either. I'm not sure when this problem started as I don't use my scanner (SCSI) and modem much. None of these devices are working. All USB devices however are working and so are system devices such as drives, keyboard and mouse. 'Install new hardware' does not pickup any new devices.

Is there a way of rebuilding the contents of the device manager?

  GANDALF <|:-)> 11:40 01 Jul 2004

Check the Plug and Play Service to Startup in MSCONFIG To check on the status of the Plug and Play service from within MSCONFIG, perform the following steps: Click the Start button, click Run, and then type in the Open box msconfig. Click OK. The Microsoft System Configuration Utility window appears. Click the Services tab. Verify that the Hide all Microsoft Services checkbox is not checked; if it is, uncheck it. Scroll down the list of services until you see the service named Plug and Play. Click to check Plug and Play if the box is currently unchecked. NOTE: If you are still having difficulty accessing the Device Manager or the Status displayed in MSCONFIG is listed as Stopped, proceed to the next section to enable the Plug and Play service. Enable the Plug and Play Service To enable the Plug and Play service in a system where it is disabled, perform the following steps: Click the Start button, right-click My Computer, and then left-click Manage. The Computer Management window appears. Click Services and Applications, and then click Services. Click the tab labeled Standard, and scroll down to Plug and Play. Double-click Plug and Play. NOTE: If a warning dialog box appears, click OK. The Plug and Play Properties window appears. Click to change the Startup Type to Manual, and then click Apply. NOTE: If a warning dialog box appears, click OK. Under the Service Status section of the Plug and Play Properties windows, click the Start button. This will start the Plug and Play service. Click OK on the Plug and Play Properties. You should now be able to access the Device Manager

  davc 15:35 01 Jul 2004

There is no msconfig on my W2K system. I searched!

PnP is enabled and automatic. All the buttons are greyed out. I am logged on as administrator.

Setting it to manual does not enable the buttons, even after a reboot.

It sounds like a permissions thing as the devices are still in the registry just nothing visible or working (scanner and modem, USB devices are working OK)

  BurrWalnut 15:48 01 Jul 2004

Just a thought but could it be something as simple as options being turned off in the View Tab of Device Manager?

  davc 19:27 01 Jul 2004

Resolution: (From Technet W2K Hardware forum)

Start button->Run

Browse to:


Click Security->Permissions

User 'SYSTEM' must be present.

If not add it and set permissions to 'Read' and 'Full Control'

You may want to add the same rights to 'Administrators'


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review: Hands-on

How to add texture to hand-drawn artworks

Best free iPad apps 2018

Comment créer un compte PayPal pour payer en ligne ?