Dell In spiron 1720 wi-fi failure

  Pineman100 14:05 19 Mar 2012

My daughter's laptop (Vista) yesterday suffered a glitch and shut down. On restarting it started up normally but wi-fi failed to work. (I wasn't present but that's how she explained it to me).

I have checked that wi-fi is switched on. I know the router is operating normally because I'm now using her husband's laptop via wi-fi via their router (BT Home Hub). I have looked in Control Panel> Network Connections and there are no networks listed. No matter how I search for the wireless network the computer fails to find it, or any other network (it usually sees their neighbour's).

In Device Manager, under the "Network adapters" heading, almost everything has a yellow exclamation mark against it. Here's how it looks - everything has the yellow exclamation except the item I have marked:

Bluetooth Device (Personal Area Network) Bluetooth Device (RFComm Protocol TDI) (No yellow exclamation) Broadcom 440x10/100 Integrated Controller Intel Pro/Wireless 3945ABG Network Connestion isatap. {E209052E-9308-4C86-BEEA-713C485A2C2C} Teredo Tunneling Pseudo Interface WAN Miniport (IP) WAN Miniport (IPv6) WAN Miniport (L2TP) WAN Miniport (PPPOE) WAN Miniport (PPTP)

All the error reports read the same: "The device is not working properly because Windows cannot load the drivers required for this device (Code 31)". I have tried installing the drivers for the Intel Pro/Wireless device (the system found two - one marked Intel and one marked Microsoft - I tried both) but I got the report: Windows cannot install the drivers.

Do you think the computer's wi-fi card is dead?

  Nontek 14:25 19 Mar 2012

Maybe a long-shot, but have you tried a System Restore back to before the glitch?

  Pineman100 14:29 19 Mar 2012


I just put the Dell Drivers & Utilities CD (that came with the computer) into the optical drive, and searched for a driver for the Intel Pro/Wireless 3945ABG Network Connection. Device Manager searched the CD and reported "The best driver software for your device is already installed".

So it looks as though the drivers are already there.

I've also checked the BIOS to make sure that the wi-fi finction is enabled, and it is.

Any ideas please?

  Pineman100 14:30 19 Mar 2012

Nontek - yes, I've tried two restore points. Both failed to restore!

  onthelimit1 14:34 19 Mar 2012

If Nontel's suggestion of a System Restore didn't work, I'd be tempted to try uninstalling all those items with the yellow exclams (from device Manager), then restart windows and let it install the drivers again. Not always successful, but has worked for me in the past in a similar situation.

  Nontek 14:38 19 Mar 2012

onthelimit1's suggestions sounds good to me!

  Pineman100 14:56 19 Mar 2012

onthelimit1... thanks a million! Success!

Thanks to you both for your help - much appreciated!

  onthelimit1 18:38 19 Mar 2012

Great - thanks for letting us know.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Razer's Core X GPU enclosure hands on review: It's cheaper, bigger, and even works with Macs

MacBook Pro keyboard issues and other problems

E3 2018 : dates, conférences de presse, billets et plus