dell battery charging problem ? bios update 'rom not valid'

  willyv 10:24 03 Nov 2012

hi all, i am trying to fix my dell 1735 laptop charging problem. basically it has to be plugged in because the battery is not charging. i have ruled out a dead battery by pressing battery test button and it seems ok. i have read on a few forums that it may be due to charger not talking to the battery due to out of date bios drive. it is running a04 and believe it should be updated to a05. i have tried to do this via dell website but when i try to flash the bios it says ' bios update could not be performed due to valid rom image not found'. i dont know if this is because i upgraded vista to windows 7 a few years ago. any help gladly received as im banging my head against the wall on this one! ta

  Fruit Bat /\0/\ 10:33 03 Nov 2012

Laptop Battery not showing Charging

  1. Turn off the computer,
  2. Take the battery out
  3. Take out the power supply
  4. Push the power button down for 30 seconds.
  5. Reconnect power supply
  6. Then the battery.

This is because sometimes the mother board gets static and this clears it and the reason it showed not charging was because it was fully charged.

  onthelimit1 14:00 03 Nov 2012

If the power led is flashing white then 4 orange, it's probably the battery. Can also happen if using a replacement, non-Dell charger.

  willyv 15:35 03 Nov 2012

fruitbat you legend!!! thank you.

  Fruit Bat /\0/\ 16:37 03 Nov 2012

You're welcome

Lost lick on aegrey bx on the right of the thread to tick as solved.

  willyv 13:48 06 Nov 2012

strangely after a few days of working fine its doing the same again and not recognizing charger/ white light not staying on. maybe the bios does need sorting???? help again!!!!!!!!!!!!!!!!!

  Fruit Bat /\0/\ 14:58 06 Nov 2012

Do the same again and see if it cures it again and how long it lasts.

  Nontek 15:37 06 Nov 2012

If none of the above works, try a new CMOS battery.

  willyv 08:08 07 Nov 2012

fruitbat, i repeated the steps and it doesnt work. back to square 1 with battery nt charging, no white light staying on and power charger not recognized message on bootup. bah humbug. i'll see if i can find a coin battery...........

  willyv 22:33 09 Nov 2012

it lasts 1 full charge before buggering up again..............

  rdave13 23:04 09 Nov 2012

I'd be inclined to go to Dell forums with this problem as it seems it is their software (for battery charge) that is at fault.

Personally I'd leave it to Win 7 to monitor but have no idea how to disable Dell's one.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)