Defrag will not run before Chkdsk

  John Crowter 13:02 10 May 2005

I am trying to run Disc Defragmenter on Partion C, but as soon as I press Analyze or Defragment I get a message saying "Disc Defragmenter has detected that Chkdsk is scheduled to run on the volume: (C:). Please run chkdsk /f".

At the Run command I amd typing "chkdsk C: /f" and getting the reply, "Chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the next time the system restarts? (Y/N)" To which I type "Y Enter".

Next time the system restarts nothing out of the usual happens - there is no sign of Chkdsk running - and I get the same message as above when trying to run Defrag.

Can someone get me out of this circle of confusion please.

  Klof Ron 13:41 10 May 2005

Not sure you require the C: switch, try entering chkdsk /f at the command prompt, and reboot as required.

  gudgulf 14:05 10 May 2005

I found this on how to cancel a scheduled CHKDSK scan once you have clicked on "Yes" to a check on reboot.Maybe you can use it to reset your system and allow the defragmenter to work click here

If it does the trick try CHKDSK again to make sure that it is functional too.

  John Crowter 17:55 10 May 2005

Tried to run Skndsk without the C: handle with exactly the same result.

The link above looked hopeful. I edited reg as it said but still no defrag. Rebooted and reg had reset itself as before. I now edited reg to H: rather than C: then rebooted. Chkdsk started checking H partion. I cancelled this and then when it had booted the reg had adjusted itself to make no reference to checking as per above Link. But still when I tried to defrag it came up with the schedule message as at the beginning.

Thanks for suggestions so far, but we are not there yet.


  John Crowter 11:21 11 May 2005

No more thoughts, gentlemen ?

  gudgulf 11:53 11 May 2005

Maybe time to try a different defragmenter....Diskeeper Lite will do a good job click here for the problem with CHKDSK and Windows own defragmenter have you tried a system restore?.

  John Crowter 19:31 11 May 2005

Problem is solved !

Have been searching other sites and found the following:

Boot from XP CD and go into Recovery. Run chkdsk from there. When finished Exit. Reboot as normal and Run "sfc /purgecache".

That's it ! Defrag now runs OK !

Thanks to all for your time.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)