Dead netbook? Refusing to boot...

  robzwolf 13:52 12 Dec 2010

My sister has an Acer Aspire One netbook. It's running Windows XP Home SP3 (well it was). After it appeared to have died (Windows having all sorts of problems) I resolved to reinstalling Windows XP. My Medion Akoya Mini E1210 netbook came with an XP Home SP3 recovery/installation disc, however, my sister's did not. Because the computer is a netbook and it does not have a CD-ROM drive I did some research and found that it was possible to put the disc info on a memory stick using WinToFlash. I did that. I booted to the memory stick on my sister's netbook, and was presented with...

1) Text installation
2) GUI installation
3) DEBUG fix hal.dll missing errors

and a bunch of other items like multi(0)/partition(1) or stuff like that

I chose the GUI installation first, but that just got a hal.dll missing error. I chose the DEBUG option but that didn't work and I immediately got an I/O error thingy next to it.

So I chose the text installation and that worked. I tried 'repair' but that just resulted to a command prompt DOS thing opening asking me for an administrator password (blank) and ended up just showing C:\Windows> or something like that.

I booted back to the text installation again and just chose to install Windows. I did all that, although there were a few missing files along the way which I just told it to skip:


and about four or five more ia and iO type files. After researching about the files, they seemed to be something to do with Intel (not the ssc.exe one though).

Eventually, the netbook restarted. I had two options to boot into (on the hard drive):

Windows XP Home Edition
Windows XP Home Edition

I only remember that the first one didn't work, so I tried the second one. This booted and continued installing Windows in a much more friendly GUI interface. It asked me for name, organization, time, time zone etc. I filled them in, and let it continue installing. At the end, the computer restarted and now it won't go anywhere. I can boot to the memory stick and am presented with the above boot options (about installing Windows) but none of them work now, the text one just says the same cannot find hal.dll message. When booting to the hard drive, I get two xp boot options (as above). When pressing F8 for more details and options I am presented with options like 'Safe Mode' and 'Last Known Good Configuration'. The top Windows XP option just says a hardware error. The bottom one shows the friendly Windows XP booting screen, then suddenly crashes a few seconds later, shows a BSOD very briefly and then restarts the computer. If I choose 'Disable Automatic Restart on System Failure' (or something like that) by pressing F8 at the XP boot menu then I can read the BSOD. I just get a similar hardware error. This is the 'technical information' shown in the BSOD:

*** STOP: 0x0000007B (0xF7A6A524, 0xC0000034, 0x00000000, 0x00000000)

It also suggests to run CHKDSK /F. I remembered that I saw a DOS/command prompt type screen when booting to text installation on the memory stick, but, as I told you before, that no longer works. I can't get into Windows now at all and the system is unusable. I do have access to the BIOS, however.

Help! Should I seek proper help from a professional?

  Batch 14:12 12 Dec 2010

When I reinstalled XP from a USB drive onto my Acer netbook, I had do do the Text mode install which when through it's business and then automatically rebooted and for the GUI mode install. I.e. it was a two stage process.

However, the Acer comes with a recovery partition and maybe you should have tried that first (maybe you still can, by hitting ALT+F10 at the BIOS screen immediately after hitting the power on button. Google for Acer eRecovery for more info.

If the Acer eRecovery doesn't work and you still want to reinstall from a usb stick, one further point from my experience:-

After the text mode part of XP install had gone through and the install rebooted to go into GUI mode, I got message about missing / corrupt HAL.DLL. This was caused by the boot.ini not pointing to the correct disk partition.

I think this was a combination of two things. Firstly the rdisk (in boot.ini) should have been 0 (meaning the first HDD) rather than 1 (meaning the 2nd HDD). This might have been caused by the USB flash appearing as the first disk (i.e the netbook thinks it is a hard disk) and so making the real HDD apppear as the second disk during the first part of the install.

Secondly, as the Acer Recovery was on the first partition, Windows was on the 2nd. so the partition needed to be changed from 1 to 2.

I can't quite recall if I fixed this via Recovery Console and/or editing the boot.ini on the pen drive - but I got it working in the end.

  Fruit Bat /\0/\ 15:41 12 Dec 2010

click here

  robzwolf 20:11 15 Dec 2010

Thank you so much! I myself have a Medion netbook (E1210) which has an obvious recovery option (just press 'F3' when the computer starts). I looked for such an option on the Acer netbook, however, I couldn't see one. The Acer eRecovery solved everything, including having two copies of XP Home installed, and the hardware errors (which I suspect were just driver errors)! I should have just googled 'Acer recovery' or something before I just went blazing in. I did the same as you, i.e. I chose the text install, it rebooted, I booted to the memory stick again and it booted to the GUI install by itself :-)

Thank you for all your help!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

HomePod review

Les meilleurs logiciels de montage vidéo gratuits (2018)