Dead Laptop

  sil_ver 13:47 11 Apr 2010

Compaq Presario cq50
This is a lappy I rashly said I'd have a look at as my knowledge only extends to the repair/build of PCs.
The problem: completely dead, no lights, no sounds, nuffink. Tried removing battery and holding down start button for best part of a minute. Tested power pack volts at 19v. tried alternative pack, still nowt. My deduction is that power is getting to lappy but being 'blocked'. Question: Is there a fuse or internal power distributor inside the lappy that has died and not economically fixable? So far as I'm aware the lappy has not been dropped and the HDD was removed to successfully recover some data. The last time it booted I was told it got so far then did memory dump and was switched off by owner 'cos she thought it was wiping HDD, after which it was 'dead'

  Technotiger 13:50 11 Apr 2010

Could be something as simple as dead CMOS battery.

  sil_ver 13:57 11 Apr 2010

Wouldn't kill it completely tho' surely?

  Strawballs 14:05 11 Apr 2010

Common problem with laptops is the small pin that the transformer plugs into can become loose from the motherboard I had an HP pavillion with a 3 yr warranty and in those 3yrs it had 3 new motherboards for that reason in fact the last board had a compaq bios as HP now own them.

You can have a new socket soldered back onto the board at a repair shop, I have been quoted about £75 pounds at one near to me for an old Fujitsu laptop I was given recently with the same problem.

  Technotiger 14:27 11 Apr 2010

Kill it completely? .... probably not, though I have seen a dead laptop come to life again after only replacing CMOS battery.

  sil_ver 14:35 11 Apr 2010

Thank you Strawballs for your input which bear in mind but at the back of my mind I think back to the 'crash'. If the lappy was low on power wouldn't it have flagged it up before attempting to boot?

  Strawballs 15:53 11 Apr 2010

If there was charge in the battery or power getting through you should still get the post screen from the bios even if windows was totally corrupted

  sil_ver 16:33 11 Apr 2010

So far as I can ascertain the machine started to boot but - presumably - got the BSOD followed by the memory dump. I can only assume it got past POST.

  Fruit Bat /\0/\ 17:50 11 Apr 2010

Are you powering off mains with battery removed?

  sil_ver 22:26 11 Apr 2010

Hi Fruit Bat

Tried powering it with and without battery and using the trick of holding down power button for about 45 secs. Power doesn't seem to be getting to the lappy as there is no sign of life in either mode. Alternative power supply tried as well.

  Fruit Bat /\0/\ 23:32 11 Apr 2010

Remove DVD drive and retry
Remove HDD and retry may boot to error message

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?