Is this a dead HDD??

  Boluwd 12:19 24 Dec 2008

I cannot get windows XP to boot this morning. The OS is on a C:\ partition on a SATA diskdrive (non Raid). Bios sees the disk but after "Verifying DMI Pool Data" message, I get "A disk read error occurred. Press Ctrl+Alt+Del to restart".

Is this the end for that this what I get as a Christmas present for carrying out a defrag on the disk last night?

All help greatly appreciated!

  birdface 12:36 24 Dec 2008

Will it start in safe mode.[just keep tapping F8 as the computer starts.] If so try a last good configuration or system restore.

  PalaeoBill 12:37 24 Dec 2008

Whilst a defrag could stress a drive that was "teetering on the edge" into a failure, it is more likely that the defrag has merely caused a corruption.
Can you boot from the recovery CD or an XP master and try a repair?

  Terry Brown 12:37 24 Dec 2008

If you are confident about opening the machine,un-plug the power cable and the data cable to the Harddrive and reconnect.
Occasionly the is a small 'glitch' in data connection,[ Harddrive will still be reconised, but will not run] which will cause the problem, or possibly (as we are constantly advised), the harddrive has failed, due to the workload (in which case it was due to fail anyway).

Can you connect the Hardrive the another machine to test it.
Finally in Google enter 'hardrive test' , with the speech marks, and see what comes up.

  johndrew 12:50 24 Dec 2008

It is possible the HDD has failed but it may be corrupt boot files/BIOS/bad connections. I can think of three things you can try:

1. Check the power and data lead connections at both the HDD and (data only) motherboard. If you have more than one HDD check all.

If the problem still exists,

2. Go into BIOS and note all your settings then find "Load Fail-Safe Defaults" select this, `Save` and exit.

If the problem still exists,

3. Insert your XP CD and boot into the Recovery Console at the prompt type, `Chkdsk C: \R` press `Enter` and sit back and wait.

If none of the above work post back and perhaps we will be able to think some more.

  Boluwd 13:44 24 Dec 2008

Thanks all.
I have managed to boot up using the XP Boot floppy.However, if I remove the floppy and try without, I still get the disk read error message. This suggests a corrupt MBR. I think I need to copy the Boot.ini and NDLR files from the floppy to the hard disk. Does anyone know to where exactly these should be copied?

Also I tried the recovery console using the XP disk, but I got as far as C:\windows prompt; I didn't know what to type next!

  Fruit Bat /\0/\ 14:16 24 Dec 2008

got as far as C:\windows prompt; I didn't know what to type next!
fixmbr, fixboot, exit.


followed on completion by c:\fixboot

followed by remove the XP CD and type c:\exit

the machine will reboot and hopefully boot into windows.

  Boluwd 15:04 24 Dec 2008

Fruit Bat /\0/\ and others,

I have run fixmbr and fixboot in the recovery console but still no joy. It looks like the only way to boot up windows is by leaving the floppy disk in and set as first boot in the BIOS. At least I know that the HDD is not buggered!

Thanks all for trying to help, any further suggestions will be appreciated......seasons' greetings etc!

  Fruit Bat /\0/\ 15:14 24 Dec 2008

Is it still showjng disk read error after running fixmbr?
or do you get a different message?
what exactly is on the boot floppy you are running is it as follows:

three files

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="First harddisk, first partition" /sos
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="First harddisk, second partition" /sos
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="First harddisk, third partition" /sos
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="First harddisk, fourth partition" /sos
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Second harddisk, first partition" /sos
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Second harddisk, second partition" /sos
multi(0)disk(0)rdisk(1)partition(3)\WINDOWS="Second harddisk, third partition" /sos
multi(0)disk(0)rdisk(1)partition(4)\WINDOWS="Second harddisk, fourth partition" /sos
C:\="Previous Operating System on C:\"


  daveeb 15:18 24 Dec 2008

I had the same problem a while back and tried all of the above to no avail. In the end I had to do a complete wipe and start again. Even this only lasted a few months so i replaced the drive (which is now surprisingly working fine in an external caddy drive).

  Boluwd 17:48 24 Dec 2008

Fruit Bat /\0/\, yes, I still get disk read error.

The boot floppy only has the 3 files, boot.ini, NTDETECT.COM and NTLDR.
The boot command is as follows
[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn

This is weird, but at least I can use the computer as normal as long as I boot with the floppy. Have tried fixmbr, fixboot, check disc etc to no avail.
Bit of a bummer, but at least all my data is on separate hdds.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?