Data recovery from slave drive

  alnwrd 22:00 07 Dec 2004

I have important data on a hard drive which I want to recover to the new hard drive. I have removed the jumper and slaved it to my new hard drive. However in my computer, right clicking does not show the slave, nor does it appear in windows explorer, but it does show in device manager as being there and in good working order. I have tried it as a slave on both a win2000 prof. and winxp prof. service pack2 but I cannot acces any files. I tried running partition magic, and the drive shows up. I tried copying the partition to the new c drive but upon reboot the computer will not boot. That's not a problem as I can reinstall the operating system but how do I access the data?

  Blackbutt_Rob 22:16 07 Dec 2004

Before going into more complex solutions, I assume that you went into the CMOS and checked that your mainboard could "see the drive".
Please be aware that the OS relies on the CMOS to "discover" the drives.
If you haven't done this step, although quite simple, it could account for the plethora of problems you're encountering.
If you have done this AND the drive was detected, then there could be a "clash" if the old drive and the new drive BOTH have active partitions. Use one of your tools - Partition Magic - to ensure that the "slave" drive does not have an active partition.

  Jeffers22 22:25 07 Dec 2004

When you say you have "removed the jumper and slaved it to my new drive" I assume you mean that you have in fact replaced the jumper in the slave position, not just left it off. If the old drive's jumper is set to slave, check the new is set to master rather than cable select.

Your motherboard should have an autodetect facility for hard drives unless it is pretty old, so I think it possible that the slave jumper is incorrectly positioned or the disks are connected incorrectly to the cable - the master should be attached to the second connector. You should also use partition magic to set the second disk to logical rather than primary and active as suggested above. It should then just be a simple drag and drop operation.

  alnwrd 22:27 07 Dec 2004

Blackbutt_Robb Thanks for the suggestion I will try that tomorrow at the office. Fingers crossed.

  alnwrd 22:35 07 Dec 2004

Jeffers22 - Yes the ide cable is correctly connected. The old drive does not show the need for jumpers ,but I have tried a jumper in all possible positions plus none at all.

The computer is a new one from novatech.

The possibility of reclasifying the drive's partition could be the answer. Thanks!

  alnwrd 21:25 08 Dec 2004

Mystery solved, the drive had somehow lost its partition which is why it showed up as a drive but explorer could not read it. I downloaded some data recovery software from tucows which allowed me to see and recover all the files.

Thanks for your help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?