damaged drivers for cd/dvd rom

  charlie 2 18:03 03 Jul 2011

hi lost internet connection error in tray says lan connection unplugged but changed lead to modem twice seems like socket on computer no separate network card fitted, also drivers for cd/dvd roms show fault in design manager yellow markers so cannot re install dell recovery disk or re install anything help help i have to use friends computer to send this windows xp dell 4600 chas

  EARLR 18:20 03 Jul 2011

What OS? You can try this: delete cd/dvd drive in device manager - reboot. this will re-load the drivers.

  charlie 2 13:05 04 Jul 2011

hi earlr Thanks for reply, os is XP have tried your suggestion but on re boot drivers are still corrupt. Hoping to download driver of cd/dvd drive to memory stick on another computer to install driver but tried this once and did not work. Cannot do anything till cd/dvd drives work. Going round the bend


  Fruit Bat /\0/\ 15:04 04 Jul 2011

drivers for cd/dvd roms show fault in design manager yellow markers

Highlight right click and select properties - what is the error code?

  charlie 2 16:46 04 Jul 2011

hi fruit bat cannot remember error code, will have to get back to my computer to check again 39 rings a bellbut not sure. meanwhile have been adviised fault is in registory and there is a procedure to correct this by going to regedit but seems quite complicated. procedure called fix missing optical drives. typing this on applemac so bit clumsy


  Fruit Bat /\0/\ 19:27 04 Jul 2011

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41 Try this if the optical drives are not appearing in My Computer or Device Manager. (This is sometimes caused by the removal of Roxio or other writing software.)

http://www.dougknox.com/xp/utils/XP_CD-DVD-Fix.zip Download XP_CD-DVD-Fix.zip and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect. This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7. You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes http://support.microsoft.com/kb/314060/ works for vista or XP


or manual fix Run regedit and navigate to registry key HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If in doubt make a restore point before making changes.

  charlie 2 14:51 05 Jul 2011

Hi I was given the registry fix info yesterday and it seems to have worked I can now access the cd/dvd roms thanks everybody. Next problem is the error in tray lan connection unplugged, I have changed ethernet lead twice to no availe. This error for network unplugged is shown all the time. There is no network card, it is onboard so I may have to fit a seperate card but I have obtained a network driver so now that I have the cd rom working I will try this first. Anyone had this error show up in the tray before Thanks all


  woodchip 15:01 05 Jul 2011

if you are using a broadband router, turn it off for five minutes then back on with the switch on the router, it may have a button at the back

  charlie 2 14:37 07 Jul 2011

hi registry fix only seemed to last until next boot up then problem returned, have repeated this a number of times. have fitted pci network card in place of onboard one but is not recognised in device manager and do not have disk. latest problem is on bootup small network window appears saying I or a program is requesting information from cr-tools.google.com and the computer is locked up for about 30 minutes with nothing available. To top it all the internet light on the modem went off, after about 30 minutes of waitingTalkTalk said the modem had lost my username and password and to replace them using computer but the computer cannot see the modem because of faulty onboard network card or unrecognised replacement. Not sure if all my attempts are making things worse or there is a major fault somewhere after thunderstorm last week So can anybody HELP


  charlie 2 14:03 08 Jul 2011

Hi eventially got pci network card installed and checked out modem using, so now on line at last. Problem with cd/dvd rom still occurs on bootup so registry fix has to be repeated each time so will have to work at this. Thanks for interest everyone, any good tips welcome.


  EARLR 10:09 10 Jul 2011

Perhaps the cause of the problem is hideing in system restore (like a virus can) Have you ran mailwarebytes ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)