CyberLink Power DVD up the Swanny

  Border View 13:11 19 Dec 2003

I run with Windows 98SE. Athlon Processor 800 mgh 128 SD Ram 30Gb HDD. Have a Samsung combo CD-RW/DVD reader. Also have Go Back installed together with AVG and Zone Alarm.

Yesterday I had a go at installing a game – Medieval Total War – Came with two discs and the installation took about 15 minutes. At the end of the installation I opted not to “launch” there and then. When I returned and clicked on the shortcut on my desktop it asked me to insert the correct CD. I tried both without success. After the fourth attempt the CD currently insitu was making some strange sounds in the CD draw and then when I pressed the button the draw would not open. Telling myself not to panic, I pressed the restart button and engaged Go Back. Reverting the drive to at least an hour before I had installed the game. I have used Go Back before and it usually took about four minutes – this time it took at least half an hour to revert. The draw opened then without problem. Put the game back in the box and in the cupboard.

Decided to defrag whilst I was at it. This took from 4.30 until 7.15. I have only used about 35 percent of my HDD.

This morning I had a go watching a DVD and the Cyber Link Power DVD software would not respond. Tried a couple of DVDs without success. I did try watching Matrix which does not use Cyber Link Power DVD but another piece of software and this worked great.

Obviously there must be something wrong with Cyber Link Power DVD software. I have an Evesham computer and I seem to recall that the software for Cyber Link Power DVD is on the Evesham Consumer Support CD (Version 2.0). I have the appropriate code number needed.

Can anyone please, please take me through the steps on how to put my problem right.

  Border View 14:10 19 Dec 2003


  Stuartli 14:13 19 Dec 2003

PowerDVD (I now have version 5) works without problems for me - it did both with and without the update patch available on the website and with both Windows98SE and XP Pro.

However, version 4 which was being used by a friend on his system would not play DVDs properly if they were copyright versions; it kept coming up with the error message that the TV Out port was unavailable.

After some research it emerged that he needed the final version of the 3dfx drivers for his Guillemot Maxi Gamer Banshee graphics card; once installed PowerDVD worked as it should do.

  PA28 14:26 19 Dec 2003

It sounds as though this problem may be a bit deeper than Power DVD - just under 3 hours to defrag 10Gb of a drive is excessive in my experience, no matter how badly the drive was fragmented. Any other views here? Barmoor, how's the machine running otherwise - is it sluggish overall? My first suggestion would be to uninstall PowerDVD (you may need to reinstall it first if it's been damaged) and then reinstall either this or another DVD player (I use WinDVD without problems). But like I say, this might run a bit deeper........

  Border View 14:41 19 Dec 2003

Thank you for responding.

PA28 - everything else seems OK. In fact last night I thought things were working faster than usual. I thought about unsinstalling Power DVD but when I tried accessing the Evesham Consumer Support Disc all I got was a tutorial on Windows and cant find the software for Power DVD. I know its in there somewhere because about two years ago I had to reinstall (hence I have the code number).

I've just had another go at playing DVDs (PC Advisors) and whilst they ran fairly well they kept freezing. When I try playing Snow White and the Seven Dwarfs (OK sad) it wont go at all. Clicking on Cnt Alt Dlt I get the message that Cyberlink Universal Player is not responding.

Where do I get WinDVD from?

  bretsky 15:53 19 Dec 2003

A couple of things here, sounds like p dvd is corrupt, have you changed regions more than 4 times?

I had Cyberlink Power dvd installed on my pc when first got it, then after about a year it stopped responding to any type of movie I put in it, error message saying "windows has a problem and must close blah blah".

Uninstalled the program, the reinstalled it , no difference, and at the time I had a Samgsung CDRW/DVD combi unit, then from the advice from a friend I installed winDVD 200... NO PROBLEM.

Since then I have upgraded to an NEC 1100A DVD+R/+RW machine with Cyberlink P DVD V4.0.13....Magic!!!!!!!!!!!!!!
Cannot remember where I got win dvd from ....sorry

bretsky using win xp home ed, sp1 on a Dell dimension 4300, 1gb sdram, 1.8GHz Intel P4 180HDD, Nvidia G force graphics,nav 2002 etc etc.

Good luck......bretsky;0)

  Border View 16:16 19 Dec 2003

I have a samsung combi. I havent changed regions ever.

Dont know if it helps but I've just done a Mad Onion 3D Mark2000 test and got a benchmark score of 5762. Also played Sega Rally (my own bench mark for how the computer is running) and it played OK.

I did try running the DVD on the same DVD software that I use for Matrix DVD but got the BSOD.

I'm going to try to contact Evesham to find out where the sofware for Power DVD is. Do an uninstall then reinstall.

Does anyone else know where I could get Windows DVD please.

  Stuartli 17:56 19 Dec 2003

You can play DVDs in Windows Media Player - just enable DVD in Tools>Options>File Types.

  Border View 18:58 19 Dec 2003

Thanks for that Stuartli - off to give it a go.

  bretsky 14:31 20 Dec 2003

Try this click here


  Border View 10:16 21 Dec 2003

Many thanks for the advice. The drawer is opening and closing now no problem but Cyberlink still not responding. Will have a look at your suggestions.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6T McLaren edition costs more and charges faster

Artist Yippie Hey on 3D printing a futuristic magazine cover

New Apple Products 2019: Predicting the new Apple products coming soon

Comparatif : PS4 vs Nintendo Switch