Crummy and irresponsible adobe

  Housten 11:32 24 Aug 2011

Good morning,

I hope someone can help me with an adobe problem. I think it was on Sunday that I discovered that what I thought was IE9 on my computer was in actuality IE8, so I managed to get IE9 installed yesterday. While all this was going on I kept getting a box appear about updating adobe flash. I have been quite busy – well for me, anyway – and I didn’t want to bother with taking the time. But this box when you click on ‘Don’t allow’ ignores and reappears after, sometimes, a whole second, and will do this for up to 15 or 20 times. Well yesterday I decided enough is enough, so I said ‘allow’, and it got exactly the same result!! I spoke to a friend about it last night and he said I didn’t have the flash programme in the first place, whereas I thought I had got it some months ago. So I tried to download it this morning, got nowhere! So I tried their live chat thingy and I must have spent over three quarters of an hour on it, with the advice to contact to get help. He gave me a link to download it, this didn’t work and then he gave me a link to instructions to download. This was interesting in that it said for IE( to go into tools and add them to trusted site. Only teensy weensy problem was IE( refused saying that the site was ‘http’ whereas a trusted site must be ‘https’ – so absolutely useless. Now the online help bloke asked me if he could open an account, to which I agreed, but if you want help from this not only do you need an account but a password as well, and I don’t have that. So I gave up and started shutting down all the IE windows that were open and found that there was a programme waiting to be downloaded, so I felt nothing ventured, nothing gained and downloaded it as it appeared to be flash player. It wasn’t, it turns out to be the download assistant! And absolutely no good to me because it uses the sites that I have already tried, about 4 or 5 of them this morning before I even got on to the ‘live chat’ bloke, and they were all useless! So I am left completely flummoxed and not knowing what to do! The first point I would like to know is if the programme is worth having? If it is then fun and games will happen when I try to download it. On the other hand if it isn’t worth having then how do I get rid of the pesky updater thing? My friend said last night I must have as it wants to install, but I don’t know now what is going on and would appreciate any help/advice/information as to what I should do. At the moment the stongest possibility is pulling my hair, but I am somewhat loathe to do that for some crummy company!

  Woolwell 11:58 24 Aug 2011

Why start another thread? Previous thread.

It appears that Flash is trying to update. The update normally takes a few seconds only. Flash is a useful part of a browser and is used on a number of webpages. Without flash you would be unable to view that content.

A Google search turns up entries about Flash, Downloads for it and help with installation snags Google Search

  RussB78 15:31 24 Aug 2011

I always get my update from 'www.filehippo' never had any problems.

  Housten 15:43 24 Aug 2011


Many thanks for your reply and I must sincerely say sorry about new thread, I had completely forgotten about the previous one ( this could be due to me being very annoyed with adobe this morning or my dementia/alzheimers kicking in. I don't know which, I just have to live with my bad memory ). I used your google search link and got nowhere, apart from some sites I visited and others I was told to visit by the 'Live Chat' bloke from adobe. This got me nowhere. I can get the download assistant but will it load and work NO. I have tried I don't know how many times to load the flash player direct, but NO go. I was working on what a friend said last night to install the flash player and let the update box do the update. But it appears that I do not have this, and can not get it to install, and so I have reconciled - after much swearing and annoying of my wife - that the crummy update rubbishy thing will keep going for some time but, I am hoping and praying for, will eventually give up. What I find most odd/worrying/annoying about the update thingy is that having ticked 'Don't allow' it doesn't accept it!! This to me smacks of appalling programming by adobe. So I was hoping someone could tell me how to 'kill' the update, but I don't think it is possible, so I am going to take my exercise now and go for a walk!

  Woolwell 15:52 24 Aug 2011

We'll try taking it one step at a time. Start here Adobe download and make sure you untick the box for Google Chrome. Try to download and install. If this doesn't work report back.

  Housten 17:07 24 Aug 2011


Thank you for taking time and trouble to read my post!

I clicked on your link, unticked the google chrome box, and what I then got was a [ very ] small box right up in top left corner of my screen. If I remember correctly [ no guarantees ] this was to download their downloader, which I must have tried 4, 5 or 6 times already today, with the same [ mostly ] result - nothing. 'Underneath', so to speak, on the rest of the screen were [ almost ] 3 dialogue boxes, which is what I think Windows uses to allow you to download many different programmes, and what reply you should give to each screen. As I have never got that far I am assuming it is what I have seen before!

  Housten 18:02 24 Aug 2011

Just a quick update to show, in my opinion, the stupid and not thought out programming at adobe. I decided a few minutes ago that as dinner was almost ready to shut down, but I saw WinASO which I got a few days ago but had not had a look round. So I did, and I found a list of programmes there that you normally only see in uninstall, and I saw flash player, dated last year. So I shut everything down and tried to install it, it wouldn't let me as there is a newer version. But what it did do was give me the address. So I went on to the internet via google to get it. It was where I have been many times, as woolwell knows, and I clicked on the download and it started up. Then when it had got a fair way through it said to shut down the internet, which I did, but it wouldn't go on. I shut it down, went through it all again and as soon as it statrted the download I closed the internet. BUT it still said to close the internet, and then I realised how stupid it was. If the internet is shut down how can the programme be downloaded. What I would call a 'catch-22' situation! Or is there something I am missing?? Could be brain, but I am not certain!

Any help/guidance/information will be very gladly received, if only to get the pesky update thingy out of the way!!! Many thanks in anticipation.

  alB 18:29 24 Aug 2011

Try this Flash version checker, also has install/uninstall options Vimeo flash version checker ...alB

  Woolwell 18:32 24 Aug 2011

If it is asking for you to close IE then it has downloaded and is trying to install. It seems to think that you have more than one instance of IE open. Try opening task manager and see if IE is still running in the background.

  Housten 14:35 25 Aug 2011

Good afternoon,

Thank you for your interest and advice, but no luck so far!


I had thought for a few seconds that you had cracked it! I followed your link, used the uninstaller, and then re-installed it! Then the updater appeared - I thought for the last time, how stupid am I? - so I clicked 'Allow', and everything is back the same way! I click on anything, it appears, I click on 'Don't allow' and one of two things happen - it either reappears virtually instantaneously or waits for my next click. This is really, really hissing me off, I can tell you!


I tried 'Task manager' and IE9 was not running, according to it! I hope this is some help for you! I don't see what it will do, do you have any other ideas?

If anyone has an idea how to get rid of this bugbear I would be very grateful!! How can it keep appearing when I have installed the latest version - which I presume is what it wants to do? - and then allowed it to update, but it doesn't want to!! Absolutely ridiculous!! [ or something approximating thereto! ]

  bremner 14:59 25 Aug 2011

Try disabling ActiveX Filtering and then update Flash Click Here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)