Could not find any compatible 3D devices

  Seadog 08:48 11 Jun 2010
Locked

Occasionally when opening one of Windows games (Freecell, Chess Titans or Solitaire for example) I get an error "Could not find any compatible 3D devices" and the program won't open.
Rebooting the computer sorts it, or if I go to the nVidia control panel and click on settings reset, the program will then open but in low quality, then I have to manually change to high quality.
The nVidia graphics drivers are the latest available.
I am running Win 7 professional 64bit.
The problem is annoying more than anything else and I would just like to try and sort it if at all possible.
I have a laptop with an ATI graphics card and the same version of windows and there has never been any problems.
Could this be an nVidia conflict?

  gengiscant 08:51 11 Jun 2010

Sometimes the latest drivers are not necessarily the best drivers, you could try rolling back the drivers in device manager.

  Seadog 09:07 11 Jun 2010

Thanks for that, but I tried that as well (should have mentioned it, sorry) I have rolled back two sets of drivers to the original ones - or at least the first ones on the pc. There have only been three sets of drivers, the pc is six months old.
I can't remember the problem occurring with the original drivers when the pc was new, but it does now if I roll back to them!!

  gengiscant 09:22 11 Jun 2010

Being an ATI man myself, currently running 2 HD 5770's, so am not sure how the Nvidia control panel works.
I did have a problem with the ATI Catalyst control center with a corrupt installation which gave me some wierd problems.
Might be worth a look.
Do you play other games, what is your graphics card?

  T I M B O 10:56 11 Jun 2010

Is this a home brew or factory made computer?

  Seadog 12:15 11 Jun 2010

Its home built - a shuttle sx38 pro barebones with 1Gb nVidia 9800gt graphics card, Q9400 quad core 2.66 processor and 4Gb RAM, 2 x 500Gb HDDs.
I don't play games much - although it was built to be able to. I have played the likes of Modern warfare 2 with no bother.
Like I said, the problem is more annoying than anything and is not there all the time. It just seems to appear every now and then.

  T I M B O 12:21 11 Jun 2010

If you dont have the old drivers at hand, it is possible to get them if you so wish. I tried an update some months ago, my graphics went mad, so i went back to the old ones.

  Seadog 12:46 11 Jun 2010

The original drivers are still on the pc - or at least the ones that originally came with the card. I have updated them twice since. However, if I roll back to the original ones the problem is still there.
Maybe if I uninstall all the drivers then re-install the original ones it might be ok.
However, I can live with it for now, I was asking in case it is a known bug or something with nVidia and Win 7 64 bit.

Then again it might have something to do with the DVI/usb KVM switch I use - I have my old pc and this one linked and I did have a problem with the graphics on the Xp machine after updating those drivers (also nVidia) - on switching to the Xp machine the screen resolution reverted to the lowest setting however, rolling back the drivers cured that problem.

  gengiscant 16:39 11 Jun 2010

Just read your last post and I am tending to agree that it might well be the usb KVM switch,I cannot remember what make of one I had but I had to alter the settings on one of my linked PC's. I upgraded to a Belkin which seem to solve the problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?