Corsair vengeance ram not working...

  Squimbles 20:24 31 Oct 2016
Locked

I wanted to check what ram I had and I opted to do it manually. After taking out and examining one I reseated it and booted up my PC. I checked my system settings and found RAM was at 4gb and not 8gb. I tried to reseat the ram again and I got the same results. I then tried swapping the two rams into each others slots. This time none of them worked and the PC won't turn on. The motherboard is still lit and when I try turning on my PC it plays three beeps that become shorter. E.g - BEEEEP BEEEP BEEP. Does anyone know what's wrong with it? I have tried resetting the CMOS by removing the motherboard battery for 10-15 minutes but I've had no luck.

  Forum Editor 08:42 01 Nov 2016

It sounds to me as if you have not properly seated the RAM modules in their slots. You need to ensure that the module is the right way round,with the notch in the correct place and that you insert it with a firm, steady push - don't insert one side first, at an angle.

Make sure the retaining clips click into place.

  Burn-it 14:14 01 Nov 2016

It also depends on whether the board, the BIOS, and Windows will detect more than 4Gb. My machine won't and it turns out that the chipset does not support it even thought many software apps say it is there. ( They just read the info from the chip NOT what is supported )

  Squimbles 15:20 01 Nov 2016

Strange. I wish I hadn't reseated it without checking. I tried the game with battlefront 3 and it seems pretty fast...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Tab S5e Release Date, Price & Spec

Robert Hunter talks animating his magical storybook style for a spaced out music video

Best iPhone & iPad games 2019

Samsung Galaxy X : date de sortie, prix et fiche technique