Control Panel display properties

  m800afc 19:45 27 Nov 2009

Windows XP Pro SP3; ASRock 775VM800; Pentium 4; 3GHz; 2Gb RAM

When I open the control panel>display>desktop the display properties dialog box appears to freeze. What is actually happening is that every single image contained within my "My Pictures" folder is being loaded and made available for selection as wallpaper. This takes a very long time, as there are many thousands of images in the folder. How can I reset the search to the default folder, and prevent this?
I have tried using the "Browse" button, which works normally, but next time I open the dialog box it reverts back to loading the entirety of "My Pictures"

  m800afc 20:00 27 Nov 2009

I do not have Picasa.
This has only been happening the last few days.

  Technotiger 20:06 27 Nov 2009

Does the same thing happen if you get to Desktop display by right-clicking on Desktop, then choosing Properties, then click on Desktop tab ?

  m800afc 20:12 27 Nov 2009

Yes, it does.

  Technotiger 20:18 27 Nov 2009

Only the last few days .... have you tried a System Restore back a week or so?

  m800afc 20:31 27 Nov 2009

I have done a system restore to a date before the problem started. It has not helped.

  m800afc 20:43 27 Nov 2009

I have just tried going into the Windows folder where the default desktop .bmp files are located. I right clicked and set the file as desktop background. The desktop background was changed accordingly. The computer was then restarted. I was hoping this may have reset the folder to the default folder setting, but it did not.
The problem persists.

  Technotiger 21:04 27 Nov 2009

Have you tried anything like Ccleaner, possibly a glitch in the Registry.

  m800afc 21:43 27 Nov 2009

Running ccleaner has not solved the problem

  BRYNIT 21:48 27 Nov 2009

Just had a quick check on Windows XP. All pictures in this folder will be included in the display properties. The only solution I can think of is to move the pictures to a different folder.

  Technotiger 21:50 27 Nov 2009

A long-shot but, turn off Indexing ...

1. Control Panel

2. Administrative Tools

3. Services

4. Disable Indexing Services

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to Watch Honor 20 Launch Live Stream

The Best Game of Thrones creative projects inspired by the hit show

MacBook keyboard issues and other problems

Comment télécharger des films sur un iPad sans utiliser iTunes ?