Connection problem driving me insane!!!

  drew645 11:47 30 Dec 2004
Locked

Hope someone can help with my connection problem.
I have a broadband connection, XP and a Athlon 3000 CPU.
Often when I connect to the internet pages load quickly but then suddenly my connection slows down to a crawl and subsequent pages download extremely slowly. If I attempt to close the page by clicking the top right hand corner the page doesn't close but a "failing to respond, end now" box appears. This will close the page but is very slow to do so. All programs load slowly, so it's not just the connection that is affected.
The only solution I have found is to restart the computer.
I have up to date anti-virus, which has found nothing. I also have checked with ad-aware and spybot for malware, but again nothing found. I use Zonealarm free firewall. All fully up to date. I have SP2 and subsequent windows updates.
Any advice would be much appreciated.
Regards,
Andrew

  smudge101 11:55 30 Dec 2004

Try opening task manager and see if any processes are using your processor an exsesive amount. You could have a program running in the background. Also some programs create a memory leak, ie they use memory but do not release it back when finished.
If as you say a reboot brings thing back to normal then my bet is on a memory leak.

  drew645 00:18 31 Dec 2004

Thanks Smudge, I checked and found internet explorer using 99% of memory while pages downloaded.
I thought changing my browser might fix it so I have installed Mozilla Firefox.
So far so good!
Cheers
Andrew

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Print designer Kelly Anna on confident mark making & modern femininity

New iMac Pro release date, UK price & specs rumours

Comment créer, utiliser et supprimer son compte Facebook ?