Computer wont boot after disconnecting slave hdd

  Rich B 18:54 18 Jan 2005


I have a MSI K7N2delta motherboard with 2 hdds connected. i wanted to remove he slave drive so that i could use it to try out Linux on, but as soon as i remove the drive the pc will no longer boot windows xp pro from the master drive.
The pc gets as far as detecting the ide drives then hangs, then it get to loading the bios and tells me the is no boot drive, i've tried having the windows cd in at this point but that doesn't load either.

Any ideas would be greatfully recieved

  Diodorus Siculus 18:58 18 Jan 2005

Could well be that XP loaded the boot partition onto the slave drive...

In the BIOS is the machine set to boot from CD?

  Rich B 19:02 18 Jan 2005

i formatted the slave drive earlier and it's completly empty.

And yes, it is set to boot form cd.

If i have the slave connected, but dissabled in the bios, everything works fine. it only stops if i physicly disconnect the slave.

  Technotiger 19:14 18 Jan 2005

Hi, maybe too simplistic, or say, just a thought
but I would respectfully suggest A) recheck jumper setting Master/Slave? B) if just the one hdd, put it on the ide cable connected at the 'centre' position on the cable i.e. not on the end of cable. C) set BIOS to boot from hdd.
D) thoroughly check all other connections inside case.

Sorry if I am 'trying to teach my granny' etc but as I said, just a thought.


  Rich B 19:16 18 Jan 2005

no that's fine simply things are what i usually forget but this time, i've tried all of those

  Technotiger 20:12 18 Jan 2005

Sorry I could not be of any help, I have been wracking my brains to think of something, but.

Still, if you wait long enough I am sure someone will come up with a better idea or two.


  Djohn 20:19 18 Jan 2005

Technotiger may be on the right track. It may be that you have the drives set to Cable select and the PC will sort out the drive for itself when booting. [Assuming the jumpers are set that way as well].

Try replacing the drive you removed and remove the current one to see if it boots, just might be that you've left the slave drive in and taken the master out. Again apologies if this has been checked but I too can't think of what else it may be at the moment..

  Djohn 20:21 18 Jan 2005

I've just noticed you have formatted the slave drive, I hope that my suggestion is way off track in this instance. :o(

  JonnyTub 20:31 18 Jan 2005

see if your pc will boot with the formatted slave as master and the other removed

  Rich B 22:20 18 Jan 2005

i've disconected the master and it tells me that it has no system disk. so i don't think the boot partition is on the slave.

  Rich B 22:33 18 Jan 2005

Try the slave drive connected on it's own but set as a master and i get the message

NTLDR is Missing

haven't got a clue what this means

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Print designer Kelly Anna on confident mark making & modern femininity

New iMac Pro release date, UK price & specs rumours

Comment créer, utiliser et supprimer son compte Facebook ?