Computer says connected but cant browse windows xp RPC unavailable.

  saunders_robert3 09:33 19 Apr 2012

Hi, i recently purchased a reconditioned desktop tower. everything was working fine until one day all of a sudden i couldn't browse the web or use anything that used the internet. At first there was a proplem with the ip address but i have rectified that problem but still cannot use the web. when i run command prompt and try register DNS its says it fails due to RPC being unavailable.

After reading numerous forums I think it must but a setting that has changed something when i have been installing new software.

Any help would be appreciated as i am a novicec when it comes to computers.

thanks, Rob.

  Taff™ 09:49 19 Apr 2012

Go to Control Panel>Administrative Tools> Services. Look for Remote Procedure Call (RPC) and make sure it is set to automatic and started. The entry RPC Locator is normally set to manual.

  saunders_robert3 10:06 19 Apr 2012

Taff thanks for the response. i have tried doin as you instructed and the RPC is already set to automatic and says started. when i go onto command promt and type

ipconfig/registerdns stills says failed due to RPC not available.

Im not sure if this is linked but i cannot open my windows firewall settings from control panel to see if it is turned off. i had macafe installed but was advised to delete it and install a new anti-virus when get my internet up and running.

  Taff™ 10:38 19 Apr 2012

Go back to services & check if DHCP Client is started and automatic.

  T0SH 12:36 19 Apr 2012

In cases like this often the simplest solution can be to use windows system restore to go back a few days before this problem occured if it fixes the issue great if not you can use "undo the last reslore" to get back to where you are now

Cheers HC

  birdface 13:30 19 Apr 2012

From another Forum.

The RPC server is unavailable because the service couldn't function properly because it's dependancy (server service) couldn't start... I checked the dependencies through the server's properties and I looked through services and started those required dependancies to start the server service, once that started... Everything functioned properly. Sorry, didn't mean waste the thread. I just hope this thread will come handy to those who stumble upon it through google with a similar problem. xD

Looks like Taff™ is on the right track so looks like you have to get others to run as well.

Myself I would not know what to be looking for.

  saunders_robert3 18:40 19 Apr 2012

Taff, the DHCP is set to automatic but is haasnt started. i tried to start it but got an wamrimg box saying

"couldn't start DHCP client service on local computer

Error 1075: the dependency service does not exsist or has been marked for deletion.

  Fruit Bat /\0/\ 19:23 19 Apr 2012

try here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)