Computer doesn't recognize KindleFire1 triggers multiple empty drives

  Ms_Dial 21:04 24 Sep 2013

I apologize if I'm posting this in the wrong forum. I tried the Win7 forum, but after an hour and 23 views I thought I'd do better trying this forum as you guys tend to know anything & everything. :)

Alrighty, here's my computer info:

Win7 Home Premium.

eMachines Model #: ET1352G.

Athlon(tm) II X2 260u Processor 1.80 Ghz RAM: 4.00GB (3.75GB usable)

64-bit OS

Here's my problem:

The last time I had to directly download a book into my Kindle Fire it took several tries to get the Kindle recognized by Win7. The computer would briefly "see" the KF but not acknowledge it. Instead, it kept seeing it as another u.s.b. drive each time it was unplugged then plugged back into the port. (It took doing this several times before it signaled recognition of the KF.) Only now I have drives F, G, H, I, and J sitting there, open and empty. I'd like to delete them, if it's doable. Could anyone help me, please?

Thank you,


more: click here

  lotvic 21:22 24 Sep 2013

The original Kindle Fire installs and shows as an external USB drive with a drive letter. I presume that is what you have.

Sounds as if you have just been unplugging the usb and have not rightclicked on the drive letter and 'ejected' the drive safely before you unplugged.

Can you confirm that that is what has happened? and you have the original Kindle Fire model and not the new HD one (as that will show as a media device)

  lotvic 21:34 24 Sep 2013

You could try refreshing the view, or closing Explorer and then reopening it to see if they clear. If not then close pc down, switch off, unplug wall plug so no power to pc, hold in tower power button for about 20 secs to clear volatile memory and residue of power. Connect plugs back up and reboot pc. This only 'sometimes' works to clear usb's, but worth a try.

Or you could try some of the suggestions on click here

Post back with what you've tried and the various outcomes

  Ms_Dial 03:24 25 Sep 2013

Yes, I have the first generation Kindle Fire and not the HD. I've had it 9 months and never had this happen before, I have rebooted my computer but not unplugged things since the original incident (2 weeks or so ago), but if nothing else works I'll do that, too.

Thanks for your help. :)

  Ms_Dial 02:35 07 Oct 2013

Tried #1 answer: Nothing greyed out for me neither under portable devices or disk drives which (on my system seem backwards (disk drives shows device types; portables devices only shows drive letters))

Steps to remove "ghost" devices from a system

Open command prompt (CMD) and do the following steps (type the following without quotes):

type "set devmgr_show_nonpresent_devices=1"
type "start devmgmt.msc" Device manager should open.
select "view -> hidden devices"
open up "disk drives"

Remove any faded out items which match with your USB drive's identifier

Reboot is not necessary in most cases, but might be a good idea.

Going on to the next solution.

2 Answer - No help whatsoever!

Try clicking on "start button" -> right click "computer" -> click "properties" -> click "device manager" (in left column) -> then click the "scan for hardware changes" button.

Going to try USBDeview from NirSoft, I give up on DIY!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?