Com Port Speed and FIFO buffers

  fredinjorox 06:55 08 Jul 2008

Following the recent help I received on my HSDPA connection, I have looked at some of the parameters of the USB modem which connects at 3.6 meg to vodafone.

The maximum com port speed I can set seems to be 460800. Is this the fastest a com port will run?

Laptop is dual core under Vista.

Also if I put mt FIFO buffers to max the connection is very unreliable, currently running at about half.

  Limariami 07:07 08 Jul 2008

Hello all

I wonder whether anyone can help me. I'm having serious USB problems and I cannot use my MP3 player, printer, or external HDD. Symptoms described below.
When i connect a device to the USB connector,
- either 'Found new hardware wizard ' comes up, but never succeeds in finding the driver (before this happened all the time)
- nothing happens (now, probably as a result of stuff I tried, this is more likely)

In both cases, a line with the name of the product (eg Zen Stone Plus) appears under 'Other devices' section (with yellow ! and ?) under Device Manager.

When I disconnect ALL USB devices, this is the info that appears in Device Manager

Under 'Other devices' section (yellow !)
- Unknown device (with yellow !)
It's position is "on Intel(R) 82801FB LPC Interface Controller - 2640"

Under 'USB Bus Controller (with yellow !) there are 11 lines
- USB Root Hub
- USB Root Hub
- USB Root Hub
Under properties, in 'Connected devices' I see 'USB Mass Storage device'
- USB Root Hub
- USB Root Hub
- Intel 82801 FB/FBM USB Universital Host Controller - 2658
- Intel 82801 FB/FBM USB Universital Host Controller - 2659
- Intel 82801 FB/FBM USB Universital Host Controller - 265A
- Intel 82801 FB/FBM USB Universital Host Controller - 265B
- Intel 82801 FB/FBM USB2 Enhanced Host Controller - 265C
- USB Mass Storage device
Its position is "0 (USB Device)"

It's strange that the PC sees a device that is not connected !

Windows XP Home Edition SP 2
ACER G91M motherboard
Intel i915G chipset

I've tried lots of different stuff, includnig:
manual and auto updating of driver (never works)
For the manual search, I browsed only to C/SYSTEM/ becase there seemed to be a lot of drivers here. Could they be storede elsewhere?
updating USB drivers (from Intel)
creating a new registry entry (to stop power from being suspended)
changed some BIOS settings

I looked at your 'USB Troubleshooting guide' and did some stuff. The guide suggests updating the (i) chipset driver and also the (ii) USB2.controller However I cannot find either. Anyone knows how to proceed?

Any feedback or advice welcome. One question in particular - should I be worried about the "phantom" device ?


  Limariami 07:09 08 Jul 2008

sorry fredinjorox

I meant to post a new thread

  fredinjorox 07:18 08 Jul 2008

If I go into control panel and select "Phone and Modems" option and check my com ports it shows the modem to be using COM 12 and max speed I can set is 460,800


if i go into device manager and look at COM ports it shows I am using COM 2 and the maximum speed I can set is 128,000

  DieSse 09:47 08 Jul 2008

"Anyone knows how to proceed?"

You'll find them on the intel site - but you need to know the intel chipset numbers first.

You can use PC Wizard 2008 to tell you about the chipset.

click here

Do you live in Limaria in Spain, near to Albox?

  fredinjorox 10:12 08 Jul 2008

I will check on the Intel site, I have downloaded PC wizard.

I live in the Sierra de las Nieves National park about 25 Km due N of Marbella

  DieSse 10:32 08 Jul 2008

Sorry fredinjorox - the limaria bit was meant for limariami - old age confusion only!

  fredinjorox 13:35 08 Jul 2008

Strangely PC Wizard reports the vodafone E220 modem to be a USB 1.1 device?

  Limariami 18:51 10 Jul 2008

Hello DieSse
Actually it's a made up name.
But I never knew of this place, thanks for telling me.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

Best Mac video editors

Idées cadeaux pour geeks et tech addicts