com & lpt port settings

  TC27 13:19 06 Mar 2005

I have been trying to sort a parallel com 1 port scanner onto my friend's Dad's pc - with the printer running throught it. He has a scorcher pc100 board & pentium 3 processor, running Windows Millenium OS.
I have just searched & learned I need to check if the setting in his bios is onto EPP/ECP. Will do, when I go next week. Will also try updating the printer's driver. (Printer already running through scanner but pc does not yet recognise scanner - even though installed it alone, first, & tried installing software & hardware every which way! Specs...Scanner: Mustek ScanMagic 600cp, Printer: Canon 1100). Also had the scanner running on my own machine already, worked fine, & it had been bought together with his pc as a kit in 1999 - thus compatible.
However, after the bios checkup, the com & lpt ports then may have to be configured/reset. Their current position is com 1 through to 6 & then lpt printer port with their own individual settings set on auto. Will this be ok or will I need to change something there that anyone could maybe shed some light on?

- Appreciate anything that may help.

Wishing everyone a lovely day.

  Fruit Bat /\0/\ 14:56 06 Mar 2005


Leave com ports on auto

Set ltp1 to epp+ecp if there is an irq setting for it it should be 7.

In windows devicve manager make sure nothing is conflicting with the port or scanner when installed.

  TC27 20:12 06 Mar 2005

Thank you very much for the advice, Fruit Bat. Will investigate the settings you mentioned.
(Also already checked for conflicts in Device Manager & there are none).
Will post 'pc's own response' to the operation - when I get there, hopefully before the end of next week.

  TC27 09:44 13 Mar 2005

Hi. Well, finally got to his machine. Printer port is set on '7.' Though I could not find any option for epp & ecp. Tracked all the settings' chains in Bios, too, & could not there find an option to 'enable' epp+ecp. Blow! Do I need to try updating the port/printer drivers at all? What is happening is that his machine still won't recognise that the scanner is there. I had installed a driver for that (for ME - his OS) which came from the same net place I had got an XP driver in order to test the scanner here, on my own machine - where it had worked fine... (plugged in & running in less than 10 mins.).

His place is over 40 miles away. May now be after Easter when I get back to it. Meanwhile I have time to investigate technicalities. Have been considering a usb to parallel converter adapter for the scanner. Even so, would be of course nice to get it running with the printer on the parallel. (Printer works fine through it). His machine has only one available usb, too, & it would also save getting hold of a hub for when his granddaughter goes around with her digital camera. (The broadband modem uses the other one).

Any possibilities?

  Fruit Bat /\0/\ 11:38 13 Mar 2005

BIOS Settings
click here

Uninstall printer drivers (keep copy of driver files)

Install scanner and get working first.

Software for scanner should have option for "through port", when activated install printer.

  TC27 14:56 13 Mar 2005

Will do, will do! Thank you for your very kind help. I will check this lot out! Also found & downloaded a new scanner driver for that scanner from the net - one which looks more reassuring.

Will check back here when I find out more responses.

  TC27 09:39 19 Mar 2005

Am going to his machine today. Will spend at least a couple of hours doing my best if need be. Have been thinking. As the machine does not even yet recognise the scanner itself, alone on the parallel port - & with the printer & printer driver uninstalled - & when the bios seems okay - would it do any good to delete the port, first? Would it be picked up again on bootup?

Will be able to pick up any reply from this thread whilst I am there.

  TC27 11:19 21 Mar 2005

Finally did it!

Thank you very much for all your help & support.
I firstly checked again in his bios - switching its option to do a full system check on bootup - instead of minimal check, fast bootup.

Also, installed the scanner driver before the scanner, for the record (then shutting down & switching off, before plugging the scanner in again & rebooting). Had uninstalled printer driver & printer, first, & then reinstalled these (driver first) after the scanner, as usual.

Well, it is all working - as it should, finally!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?