CIDAEMON FAILURE ...advice please.

  Maturin 09:28 13 Jan 2006

For sometime now my machine gest stuck in a loop telling me that cidaemon.exe has failed or WIndows Indexing Service cannot work. IT is really irritating. I found areference to this on the web and downloaded Spyware Doctor from PC Tools which found 13 suspect files, including 'ikinet' keylogger and one suspect gif file.

I am not sure what to do now. My machine is Athlon 64 3000+ with 1GB RAM and running Win XP Pro SP2 with NIS 2006. I have unisntalled MSN Search Tools which has not helped. I have also disabled Prefetch which may also be contributing to this problem apparently.


  Klof Ron 13:32 13 Jan 2006

Have you considered running a system file check?

Go to Start/Run and type sfc /scannow (note the space betweenn sfc & /scannow), put your XP disc in the drive when prompted and allow a system check to replace any missing or corrupted system files.

  Fruit Bat /\0/\ 16:01 13 Jan 2006

Process File: cidaemon or cidaemon.exe
Process Name: Microsoft Indexing Service

cidaemon.exe is an indexing service which catalogues files on your computer to enable for faster file searches.

Chances are you don't need it, and can disable the indexing service. "Black Viper" has a good overview of XP services click here.

  ade.h 18:01 13 Jan 2006

If you often search for files - as I do - the Indexing service makes it hugely quicker.

  Maturin 10:05 17 Jan 2006

I shall try Klof Ron's suggestion later this week

  Maturin 11:14 30 Jan 2006

Well, I have solved some of my difficulties - switching off Windows Indexing Service has stopped the cidaemon.exe error message barrage.

Now, I cannot run chkdsk from windows - 'cannot lock disc' error. The chkdsk CAN be run if I use Windows Recovery Console operating system and falgs no errors.

Defrag works - but I am loathe to reinstall Diskeeper because it needs to run chkdsk at bootup before it will work (at least that is the message I was getting at bootup until I uninstalled it).

Before you ask, I cannot run chkdsk after booting into Safe Mode or 'Diagnostic' startup - the same error: 'cannot lock disc'.

What do I do now?

  Maturin 16:57 31 Jan 2006

Come on, one of you must have an idea what I should do next

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?