jgosden 17:28 10 Feb 2004

i have just ordered web hosting from

when i logon via ftp and try to chmod it says its worked but it hasn't all that happens is that it leaves it at 700 but i need to chmod my perl files to 755 and 777. I am really confused by this.

Anybody any ideas?????????

my domain is click here

  jgosden 21:33 10 Feb 2004

has anyone got any ideas??? I really need to use this , whenever i chmod a directory if i press refresh it reverts back to 700?

how can i do perl like this?????????????? I am really confused any problems anyone knows of???????

  Forum Editor 23:35 10 Feb 2004

You may find that you don't have the necessary authority to set a new file permission. If you are changing the permission on a file within a directory check that the directory itself has the correct permission, otherwise it won't work.

  jgosden 08:26 11 Feb 2004

i have emailed my host to find out, it won't let me set permsisions on anything at the moment! If this is the case surely I can't use perl????

  Forum Editor 17:46 11 Feb 2004

don't like you using any cgi scripts on their server, other than those in the cgi bin. Unless you can modify permissions using CHMOD commands you're right in saying that your ability to use your own (or third party) scripts will be lost.

  jgosden 19:18 11 Feb 2004

- CGI BIN installed: Your account is equipped with its own CGI-BIN, allowing you to install and use your own CGI scripts. There are also thousands of free scripts available on the Internet for you to install and use!
click here

so when it says that you can use ones from the web then there is a way round it just don't know what this is as yet!!

  jgosden 19:19 11 Feb 2004

am i right in thinking then that there must be someway of chmoding

!!!! this is the specification of the package i bought..

  inspector gadget 21:49 11 Feb 2004

I seem to have the same problem as you click here if I get a responce from streamline before you I will post here

  inspector gadget 21:49 11 Feb 2004

P.S. I have the same package

  jgosden 22:00 11 Feb 2004

have you tried using perl?????

u seem to be on windows so is slightlyy different. Permersions are the problem here, its not letting me change the chmod to 755 or 777 which is what it should be for perl / cgi/

I am reassured to know this isn't just me, i have sent an email to streamline and am waiting for a reply but am really not impressed about this as it was the main reason i bought the package. It clearly states on the wabpage thet you can use perl scripts from the web yet does not work,

If i don't get a email soon they will have a very unhappy customer on the phone to deal with. I have used other hosts before and never had this problem and as far as i know there is nothing i can do about it. There online support i shocking and only has a couple bits of infomation about anything on , something which could be done in a couple minutes flat.

I am not pleased so they better tell me soon why i can't set permissions!!!!!!!

  jgosden 22:00 11 Feb 2004

sorry about the spelling mistakes!!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?