CD/DVD Writer can't read any Discs

  HandyAndy5535 18:03 25 Jun 2012

Hi, Would any of you wonderful people out there know what this issue may be as i have searched and searched and cannot find a solution. My mates parents H.P. Desktop P.C. suddenly stopped being able to read any discs so can't install any software or anything at all. It's running Windows XP and i have tried everything, even got them to buy a new CD/DVD Writer but when installed that and fired the P.C. up it recognises the drive no problem but yet again when i insert any CD it doesn't recognise, even when you click on the drive in Windows Explorer there is nothing on the CD's.

Anyone out there have any idea what i could do to rectify this issue as i am totally stumped now.

Your help is much appreciated.

Many Thanks


  lotvic 18:25 25 Jun 2012

Try UN-installing the drive in Device Manager, then shut pc down and unplug from mains wall plug. Now hold in the Power Button on Tower for 30 seconds to discharge any residual current etc. Wait for at least 3-5 mins and then plug back in and boot up.

The drive should be recognised as 'Found New Hardware' and proceed to install it.

Put a known good CD or DVD in and hopefully it can now be read.

  Fruit Bat /\0/\ 18:31 25 Jun 2012

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41 Try this if the optical drives are not appearing in My Computer or Device Manager. (This is sometimes caused by the removal of Roxio or other writing software.) Download and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect. This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7. You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes works for W7 Vista or XP

or manual fix Run regedit and navigate to registry key HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If in doubt make a restore point before making changes.

  HandyAndy5535 12:38 27 Jun 2012

Fruit Bat, thanks for all that informationbut i have tried everything you have said but still got the same issue. I have Uninstalled, ReInstalled both the Old and new Drives and followed all instructions but nothing happens. When you load the CD into the tray and close you get the little CD Icon nect to the cursor as if it's going to start loading but then nothing happens and when you click on the drive through windows explorer it shows nothing on the CD :(

Any further help is much appreciated by anyone as i am totally stumped why even the new one won't work either.


  lotvic 14:25 27 Jun 2012

Have a look in Device Manager -> IDE ATA/ATAPI controllers -> right click on: Primary IDE Channel -> Properties > Advanced Settings > Transfer Mode. Is it set to DMA or PIO?

Here's some info about it

  lotvic 14:28 27 Jun 2012

Adjusted link ClickHere that should work. (if paste link straight in on here and it has 2 underscores it turns the text between into italics, which then breaks the link... sigh)

  HandyAndy5535 14:55 27 Jun 2012


Just checked this and it's set to DMA

I've tried everything now with both the Old CD Drive and the New CD/DVD Writer :(

  lotvic 15:46 27 Jun 2012

Try it on PIO. That sometimes wakes it up. You can always change it back later if wanted. Reboot after the change.

Another thing to try is sfc /scannow (there is a space between c and /)

Am still searching for anything else to try. I had this once on someone else's laptop - they thought CD/DVD drive was broken, I wasn't trying to fix the drive but after a restore to factory image it worked again.

  HandyAndy5535 16:48 27 Jun 2012


Tried changing to PIO but that didn't work either, neither did sfc :( think i'm going to have to give up, it's so frustrating why it's like this. Thought a new CD/DVD Writer would have been fine but that's hopeless also.

  lotvic 17:32 27 Jun 2012

You could always get a SATA/IDE to USB Adapter Cable and plug the CD drive into a usb port (not necessarily that one, it was just to show example) at least then you would be able check that it is not the drives that are faulty.

  rdave13 19:54 27 Jun 2012

Or even a new IDE cable as it might be at fault. Unusual I know.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?