CD writers don't!

  skeletal 14:35 03 May 2004

Hi All

I have a problem that is so confusing, I don’t know how to explain it; but I’ll do my best!!

For a long time now, I have been having real problems trying to record CDs, and recently, they have been getting worse. Today, I thought I would try to sort it once and for all. The best I can do is to list all the things I have done:

1. I have an Asus CRW 5224A writer. It has always been very fussy about which CD brand it will recognise, but I have made it work OK with Maxell. However, recently, when I try to burn a CD, using Nero 5.5, I get to about 24% and the computer hangs. Task manager shows 99% idle, in other words, I don’t think it is a Windows hang (else it would say "Nero 99%", I think).

2. I thought I was the CD writer, so I swapped it for my trusty Plextor 12/10/32A, which works perfectly on another computer. The same thing happens (ie hang at 24%; hard reset to start).

3. I tried Plextools instead of Nero and very oddly got:
a) The window that should display all drives (for you to chose to start the copy process) only shows the hard drive; it doesn’t show either the writer, or my Sony DVD reader. Thus, I cannot use Plextools.
b) Under Plextools system information it says:
ASPI Installation: wnaspi32.dll; version/description/company = N/A

4. I tried NTI CD Maker deluxe. This starts the CD making process, and it hangs just like Nero, shortly after starting.

5. I tried using SiSoftSandra and it came up with an error message W2600 along the lines of the drives (CD and DVD) being SCSI, but they probably aren’t because they are ATAPI. I tried to get more info, but something happened to Sandra while I was trying to access their web site, and now Sandra isn’t working like before!

6. I loaded WinOnCD which works OK on the other computer. As I loaded it on this one, Windows complained that a driver would cause instability and to go to Roxio’s site for an update. Went there but they want my current version (which is 3.7). This is so old that they won’t recognise it, so won’t let me on the download part of the site, so I can’t download the update!!!! BUT trying to use the "crippled" WinOnCD gives another error message: "Error retrieving SCSI/IDE information: No SCSI host adaptor found."

7. Both CD drives are fine to read from (but the Asus would only read from some discs). All drivers are as up to date as possible (but given the same problem occurs with two manufacturers and several different software, it cannot be driver...but I can’t get any newer ones anyway!).

8. In device manager I am told "everything perfect".

I think that something is happening "beneath" Windows, but don’t have a clue what.

Op system is Windows XP pro; Asus A7N8X Mobo with AMD2700XP cpu, 512M DDR ram.

Sorry for long post. Any thoughts???


  kspatto 15:14 03 May 2004

sounds like a memory problem
have you got enough memory(virtual)the writer needs to be able to store an image of what is to be copied
go to control panel-system-advanced-performance-advanced-virtual memory(it will advise you on the best allocation)you can also alter the other settings to suit what you are using your pc for
hope this helps

  skeletal 17:00 03 May 2004

An interesting thought. I have 5 virtual drives, all having between 1 and 2G, and a small drive with 100M. The CD/Windows should have direct access to the 1G one. I could try switching to "let Windows manage it".

However, since the files I am trying to write are 100M and I have 512M of RAM, I wouldn't have thought it would be a problem.

But, as I'm stuck, I'll try anything!


  woodchip 17:20 03 May 2004

If I was You I would clear out all CDRW software from Computer and registry then retry loading your software not all the above but the one that worked ok before. If that does not work you may need to reformat to get rid of all the CDRW drivers but you wiuld need to backup everything including hardware drivers if you have not got backup discs and backup e-mail and docs

  MIke 18:27 03 May 2004

Going along with kspatto's theory of lack of memory, have you tried creating a disc image on hard drive first then creating a cd from that disc image?

  skeletal 19:34 03 May 2004

Thanks for a few more ideas; I've been outside cleanis=ng a very dirty car!

  skeletal 19:34 03 May 2004

Thanks for a few more ideas; I've been outside cleanis=ng a very dirty car!

  skeletal 19:34 03 May 2004

Thanks for a few more ideas; I've been outside cleanis=ng a very dirty car!

  skeletal 19:51 03 May 2004

Ooops! Things are going from bad to worse...I don't know what just happened...the screen flashed and 3 posts appeared!!!!

Anyway, try again! I was trying to say, thanks for the ideas, and I've just been outside try to clean a very dirty I'm having a look at the CD writer problem again!!

That's going from bad to worse as well. I am letting Windows manage it's memory, and have uninstalled all CD writing software. I then thought I would let Windows use its built in software. It got so far then I got a Windows error message something like: "There was an error trying to write to this CD, it may be unusable." Yet another coaster then!

Most worrying is I now get an error message every time I boot up telling me that Windows won't install CD writing software drivers as it will cause system instability. Clever me thought I would do a system restore to yesterday, ie long before I tried installing the other writing software. System restore HAS NOT got rid of the error message....WHAT???!!

I can't believe this! I thought the whole idea of system restore was it was supposed to restore the registry/exe/driver files to a previous working state!

So, not only do I still not have a working CD writer, I now have an unremovable error message.

I tried reinstalling Nero, but it now wants a serial No., which I don't have because it was a "freebe" with my CD writer!. Got to think how to overcome that.

As for re-installing Windows...absolutly no chance of that at the moment...I am hard pressed to meet a deadline for some software I am developing and from bitter experience, a re-install will take at least a week's hard work!!

I can't really try the other ideas just yet (because I can't re-install the software), but it looked like the Windows writer made a hard-disc asked me if I wanted to keep the file to try again later.

So, any ideas of how to get rid of these non-existant drivers??!!

Thanks again.


  skeletal 21:09 03 May 2004

Oh's going from worse to worser(!). I thought I would try to restore to an earlier point. All my system restore points have now gone! Thank you Windows; on the very very rare occasion that I need SR, it fails!

So, no CD writer, error messages appearing and no SR.

Good news is that I have gone into the registry and there is a lot of CEQuadrant stuff there. Thus, I don't think add/remove programs works, nor did the system restore.

I think it is time to hack the registry. I would like to make a backup first, but I have no doubt that won't work either!!!

Any further comments still welcome!


  skeletal 22:09 03 May 2004

Registry hacked. All CEQuadrat stuff gone (there was loads). BUT I STILL get the error message at startup!!

Anyone know where its comming from? I have looked in msconfig and I can't see anything suspicious in the .ini files etc.

Trouble with all this, is it could all be a red herring anyway!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Artist Pete Oswald on creating relatable characters & his new book

New iMac Pro release date, UK price & specs rumours

Idées cadeaux pour geeks et tech addicts