cd-rom wont run without re-boot

  johnpr 20:52 15 Jan 2004

when I start my pc the cd-roms load normally and open the files, however after going into my computer, settings etc. and later loading a cd-rom the pc does not regonise the disc.
When I click on the cd-rom drive It asks me to insert a disc?
If I right click the cd drive letter and go to the volumes I can see the info of whats on the disc in mb.
If I re-boot the cd opens files/autoruns as normal??

I have a cdr and a cdrw, both do the same

I have loaded the xp disc to attempt a repair with no avail.

1700XP XP PRO 512sd ram

Any help would be gratefully appreciated.

  eddie937 20:55 15 Jan 2004

i am having the same problem!!

  Pablothehat 20:25 16 Jan 2004

I have a similar problem with my dvd, reads movies ok but put a software disc in, no way, sometime wont even work after reboot

  Quiller. 20:33 16 Jan 2004

Are your cd and cdrw on the same IDE cable? i.e. secondary master and secondary slave.

It MAY be that the IDE cable has a break in one of the wires. Try using a different IDE cable if you have one or join one optical drive to the primary IDE cable with your hard drive.

Worth a try as nothing else has come up. lol

  johnpr 21:48 16 Jan 2004

I have a hdd as primary and a cdr as slave on one IDE cable and a cdrw as primary on another IDE cable.
Tried replacing the IDE cable, made no difference.

The problem only seems to occur after after going into Control pamel-add/remove programs...very strange

  Quiller. 22:31 16 Jan 2004

Yes. Very strange........


  hugh-265156 01:33 17 Jan 2004

try the hard drive as master on the primary ide by itself.cdrw as master and cdrom as slave both on secondary ide.

then (cancel the lang instal) click here

and/or click start run type regedit click ok.

navigate to:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom see "Autorun" in the right pane,click and set to a value of "1" to enable "0" to disable.

  johnpr 10:21 17 Jan 2004


I have tried to set the drives as you suggest, however, even though it worked initally the next day it wouldn't boot up untill I changed the drives back.

I have read somewhere that Norton can cause this problem by scanning the cd's and preventing them from running, has anybody else heard of this?

  Big Elf 11:22 17 Jan 2004

Wild guess here. Try deleting the drives in Device Manager and then reboot. Maybe the driver is corrupt?

  johnpr 11:55 17 Jan 2004

Thanks Big Elf, I have tried updating both drivers (from XP pro) and even un-intalling both drive and re-installing them.......still no joy

The CDRW is a Artec WRR-52Z, are there sny firmware updates out there?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts