CCleaner (free) update not working

  john bunyan 14:53 12 Sep 2017
Locked
Answered

I use the free version of CCleaner. The version I had was V5.33.6162. An update was offered, and installed theoretically but still kept the old version - not the 6207 that was offered. I tried twice, on 2 computers with the same result - (asks "do you want the new version?"). I do a custom install to miss out pinning to the start menu. Any other CCleaner users had this problem?

  rickf 16:59 14 Sep 2017

This is not free. Asking for £15 something.

  qwbos 17:36 14 Sep 2017

As I said previously at 23:47 on 12 Sept "It'll offer, but you're not forced to take it. Just click on No Thanks, then select the FREE version - left column of three"

The Free version is Free

  john bunyan 18:16 14 Sep 2017

Updated ok now. The problem was that on the first day the offered download ( wrongly) was 533 so when it installed it kept saying there was a new version. Sometime yesterday the download was 534 . This gave the correct new version .

  Bazzaman 08:52 18 Sep 2017

Something strange happening with Cc;leaner updates. See this:

"Strange" version of CCleaner appeared on PCs without warning

  Bazzaman 08:54 18 Sep 2017

Something strange happening with Ccleaner updates, see this:

Strange version of CCleaner appeared on PCs without warning

  Bazzaman 12:49 18 Sep 2017

NOW see this:

CCleaner compromised to deliver malware

In particular, note what is stated at the end:

"*The Cisco Talos researchers recommended that affected systems - of which there could be thousands - should be restored to a state before August 15 2017 or reinstalled. However, they emphasised that updating to CCleaner version 5.34 does not fix the problem as the malware will remain on infected systems.*"

  john bunyan 16:23 01 Oct 2017

As a postscript - It seems that Filehippo's link to the ccsetup 533 was compromised. My Defender found the following and quarantined it (on 29 Sept): Backdoor:Win32/Floxif, found in the following location: D:userfiles\Downloads\ccsetu533(1).exe

Now, if I get an update prompt from ccleaner, I go to the Piriform website to download it rather than the automatic prompt.

Also see:

Hacked ccleaner

I have run a complete scan (not quick) with Malawarebytes Premium and Defender and appear clear.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Elephone U2 Review

Ichijo Hikaru's riso print pop art is a celebration of the female body

New iPhone 11 (2019) release date, price & specs rumours

Les bons plans audio (2019)