Can't run my first Java programs...Help

  Kitz E Kat 20:44 06 Jul 2003
Locked

Hi, i've just started Java and am getting close to Stopping Java!!!
I downloaded SDK.
I created a file in Notepad, and saved as "Welcome.java".
I went onto DOS and using "javac" compiled the program, now have "Welcome.java" and "Welcome.class", this is all good!!!!
i now type C:\java>java Welcome... and get...
'java' is not recognized as an internal or external command... etc...

I tried this before and it did work, but not now?

The SDK is on my C: drive and the file is in a folder called"java" on my c: drive..

I uninstalled the SDK and reinstalled again, no joy..

Files that did work now don't, i get the same Msg as above...

I would like to learn Java, but im close to havin no hair...
HELP
Thanks
Kitz E Kat

Use a program called textpad instead of note pad, it highlights the coding, and allows you to compile in that.

I never tried using DOS when i done java at uni, just used text pad, and it makes life a lot easier!

Look for TextPad v4.6 from click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Print designer Kelly Anna on confident mark making & modern femininity

New iMac Pro release date, UK price & specs rumours

Comment créer, utiliser et supprimer son compte Facebook ?