Can't run MS AutoRoute 2007

  FearlessFred 11:51 12 Feb 2010

Am running Windows 7 64bit and couldn't install Microsoft AutoRoute 2007 until I ran in Compatability mode as WinXP SP2.

Then it installed OK (or seemed to) but can't run it as every time I start the Programme I keep receiving this message:

Your registry settings for this application were not copied correctly. To correct these settings, run Setup again for this application from the location where you originally installed it.

The programme had previously run successfully on my Vista system and my Laptop's XP system.

I tried: 1. followed the instructions! 2. Uninstalled and then reinstalled, (both from the original discs).
3. Used System restore to a point some days back, before previous use. (Same message). Then uninstalled and reinstalled again. Each time the wizard reports "Installation successful", but attempting to use the program results in that same frustrating message.

Don't like delvinto the Registry in case I muck it up

Would be very grateful for any suggestions


  MAT ALAN 12:06 12 Feb 2010

click here

says its compatable so you may have another underlying issue that stops it from loading...

  FearlessFred 12:13 12 Feb 2010

Thanks Mat. Yes I'd seen that when I ran the Upgrade Advisor but it wouldn't install till I put it into XP SP2 mode.

Won't run though in 7 OR Win XP SP2.

Have tried a Registry cleaner


  rawprawn 12:36 12 Feb 2010

Try right click and "Run as Administrator"

  MAT ALAN 13:56 12 Feb 2010

click here

click here

could be a installer issue the links may help...

  rawprawn 14:47 12 Feb 2010

I am almost certain it is a permissions problem, if you right click, and select Properties > Compatibility > tick the box at the bottom Run as Administator.
Mine runs fine in Windows 7 32 bit

  FearlessFred 18:42 12 Feb 2010

Thanks Mat. Did the Command Prompt as per your link - said "completed successfully" but got same message

RawPrawn - have done that. No improvement. I wonder if I should change permissions? To my name or Aministrators or System?


  rawprawn 12:24 13 Feb 2010

Hi, my permissions are set to "Everybody"
I had exactly the same problem about 3 years ago when I first used Auturoute 2007. The problem is I can't remember how it was resolved other than Run as Administrator.
If I can rack my brain any further I will post back.

  rawprawn 13:46 13 Feb 2010

Try installing it to a different Folder (Other than Program Files)
have a look here click here
Also in the Read Me it says Disable your AV when installing it
Have a look in your Read Me in Set up.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?