Can't reformat Hard Disk Drive

  toga 13:12 01 Dec 2003

Hi I am currently running Windows XP Pro on a AMD system, using a Fijitsu 40gb HDD. My system crashed the other day and I have been unable to format the disk (even when booting from a floppy). However I can access files on the disk when I boot from my old HDD (2gb with Win98 SE) but I can't delete files.

Any ideas please???

  Diodorus Siculus 13:18 01 Dec 2003

Can you boot with the 2gb disk and format the other one from within win98?

Or have you tried to fdisk it from the floppy - have a look at click here for info.

  Zinedene-285364 13:32 01 Dec 2003


Did u install XP ureself?
I would get a fresh copy of a win98 start up disk, and FDISK.
If ure XP is installed using NTFS (better than Win's previous FAT 16 &32 formats), then u have to choose the option which says something like 'delete Non-Dos partition', which is in the delete options..

Alternatively, u could pop in the XP disk, and let it start a New instalation. After a short time, you will have options to choose the drive you want to install on. At this point, there are also options of deleting existing partitions. U could also try that.

Also, is ure floppy light coming on after post test (the little 'beep' noise at beginnning).
If not, then go into BIOS, and allow for floppy disk to find OS.
I had a system that was setup not to read floppy on bootup, and couldnt work out why my Win98 start-up disk wasnt working...

hope that helps
Good luck....


  Diodorus Siculus 18:32 02 Dec 2003

Tried booting from 2gb and formating from 98se no luck. Even trying to install from win xp cd I get a report saying win xp can't format.

I think the HDD is done for.

Thanks for trying.


You're welcome; have you tried the fdisk option though? It has been know to sort a lot of problems.

  Diodorus Siculus 13:08 03 Dec 2003

I have tried the fdisk option. Fdisk reports that partitions have been deleted, when I reboot I set partitions and format. But everything reverts back to the original configuration as if nothing has taken place.

And now the manufacturers utility downloads can't erase or reformat the HDD. I will have to bite the bullet and buy a new one.

Thanks toga


Sorry I can't help any more other than to suggest that you try a low level format from a utility that may be on the manufacturer's site.

Maybe someone else has a suggestion.

  wizkidwall_03 13:38 03 Dec 2003

restart your computer go into the bios and change the option first boot it should be set to floppy or harddrive change it it boot from cd put in the win98 cd and restart then it should come up with booting from cd then select the option boot from disk then select start computer with cdrom support this should start in dos and you should be able access your cd drive the default should be a: run fdisk delete your primary dos partition exit fdisk change the drive to d: or e: by using cd e: or D: go onto cd win98 run oemsetup and it should automatically format the drive
good luck

  neko 13:45 03 Dec 2003

Just a thought,

Have you tried swapping your EIDE cables in case there is a problem there? It was the cause to a similar situation with my sisters Pc and saved a few quid on getting a new harddrive.
Does S.M.A.R.T show a problem when you boot?
If it is not enabled, enable it in CMOS. It is a good indication that your drive is on the way out.

If Fdisk doesn't see it there certainly is a problem as your file system must be FAT 32 as you can see it from a Win 98SE partition.

Can you save files from your 98 setup? If so I would certainly back up now.

Good luck

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Motorola Moto G6 review: Hands-on

The best smart speaker: Apple HomePod vs Google Home vs Amazon Echo

Les meilleurs jeux gratuits pour Mac (2018)