cant re - register a .ocx file

  William-173411 17:47 10 May 2005

while trying to correct a problem with my windows update system, I was given a solution from the MS database, it called for me to re-register several files.They were regsvr32 msscript.ocx, regsvr32 dispex.dll, regsvr32 vbscript.dll, and regsvr32 scrrun.dll. all the .dll files re-registered without a problem.but the .ocx file gave me an error message that read, " Loadlibrary ("msscript.ocx") failed, get last error returns: 0x00000485. when I went back to the MS database and looked up the error code it told me the reason was that regsvr32 could not re-register it because it was missing a library , or files. Unfortunately it didnt say which library or files it might be missing. I know from reading the article that this file has to do with Active X.Can anyone tell me what library might be missing or how I can fix this problem? I have checked my computer and there is no msscript.ocx file in it. HELP!!!!

  gudgulf 18:01 10 May 2005

It is most probably the .ocx file that is corrupt.Try downloading a new version to replace the damaged one click here
click here

You will find msscript.ocx in the Windows\System32 folder.To find it open Windows Explorer and go to Windows>System32 and left click on it to open the folder.Scroll down to find it.

  William-173411 18:25 10 May 2005

thank you gudgulf, i am running 98 second edition, so i believe it should be in my system file, but it isnt...that may be the problem??

  gudgulf 18:40 10 May 2005

Try another search but just put msscript in the search box(don't add the .ocx).See if that finds it...that worked when I checked my Xp system.

I have tried this reregistering fix on one of my pc's when I kept getting errors from the Windows update site...It didn't work!!!!

I went back to using the previous version of Windows update by using the Administrators options on the update site when it errored and scanning for updates from there.Then I got fed up and reinstalled windows/SP2 from scratch...That cured things....In fact it went wrong after updating to SP2.Not the fault of SP2 though as it transpired that I had a faulty memory stick which corrupted the intall!

Sorry for that aside...I'm just going to nip round to a neighbour and check if that file is on his Win98 system.

  gudgulf 18:52 10 May 2005

Right just had a look for msscript.ocx and it was easy to find in Wndows\System.....try downloading and adding the file then registering it.See if it could also try running Sfc /scannow to recover any corrupt or missing files.

  William-173411 19:05 10 May 2005

well i dl'd the file and extracted it to my windows system file, re-registered it and it was succesfull, however, it did not solve the update problem, it still gets to the part where the download and install window comes up and then just sits download, no install.what is sfc/scannow and where do I get it?

  gudgulf 19:47 10 May 2005

You might need the Windows Installation disc for this but go to start>run and type

  gudgulf 19:56 10 May 2005

Doh!!!!! hit wrong button.That should read type msconfig.That will open the system configuration tool.Have a look through the tabs that open up and you will find the System File Checker tool in one of those.Sorry to be vague but my experience of Win98 is limited to sorting out my neighbour's pc as and when.Hopefully someone is reading this who is more familiar with 98 and can guide you more accurately.

In Xp you type sfc /scannow (note the space)into the run box but I'm not sure if that works for 98.
What happens when you run it is Windows compares the files on your system with its record of what should be there and will replace any missing or corrupt files.It may need to get these from the original Win98 disc.So if you have one keep it handy.

  gudgulf 20:06 10 May 2005

There's always Google

click here

click here

Hope these help.

  William-173411 22:32 10 May 2005

well I followed those two links and I managed to get the SFC run, It found one file that was corrrupted or in need of repair, and it was repaired succesfully, ran the windows update, still dont work.It was then it struck me that I have another problem with the internet explorer that might be the root of the problem, when I click on a hyper link, or a "Click here" type button in emails, or some web pages, the explorer opens a new window and then does absolutely nothing, it will not execute the link. isnt the "install now" button at the update site a sort of hyper link?

  gudgulf 00:12 11 May 2005

This site might help click here

There are some tips on hyperlinks not working and IE repair etc.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?