Can't log onto Belkin website

  Nic80 20:17 02 Sep 2007
Locked

Hi I've been having some problems with my router so have tried to log onto the Belkin website. It wont load though, neither the uk or the .com one. All other sites are working fine it's just that one. This has been going on a few months now, it's only now when I have again tried to open their page after a few months I realised that I still can't get on.

Any ideas?

  VoG II 20:21 02 Sep 2007

Try HostsToggle click here

  Nic80 20:34 02 Sep 2007

Whats that?

  VoG II 20:37 02 Sep 2007

It enables you to toggle your hosts file off or on. To do it the hard way go to C:\windows\system32\drivers\etc\hosts and rename it to hosts.txt then restart your PC>

  Nic80 20:40 02 Sep 2007

I don't even know what host files are.

Can you explain please?

Can you also explain why said host would prevent my accessing the Belkin website?

  VoG II 20:43 02 Sep 2007

click here

It is only a possibility but if Belkin has been added to your hosts file then worth a try, surely?

  Nic80 20:49 02 Sep 2007

I don't trust your answer, you're telling me to install things without telling me what it is exactly.

Again, what is a host, and whats the hosts file?

  VoG II 20:50 02 Sep 2007

Fair enough. Live with your problem. Goodbye.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique