Can't installSP3 on home build pc

  Desperate-Dan 09:44 23 Oct 2008

I have tried three times to install SP3, (winxp) each time I get right to the end of the install and it says access denied, I disabled my anti-virus and firewall and tried to install it in safe mode,
but I still get access denied, and each I have to do system restore to my pc get back to how it was

I got in touch with microsoft and this what they want me to do, but to be honest I don't trust them I don't want to mess my system up, so would you please have a look at what they have sent me.

After checking the information uploaded when you submitted this Service Request, the processor of the computer is AMD. We need to disable IntelPPM service before we install SP3.

Step 1: Modify registry keys to disable the IntelPPM service


1. Please go to Start, Run, and type REGEDIT. Click "OK" to open Registry Editor.

2. In the left pane, please locate the following key:

My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\intelppm

3. Right click the above key and choose Export. Please save the file as backup in .reg format. If any unexpected issue occurs, we can restore the registry keys.

4. Highlight the above key and double click the subkey named "Start" in the right pane.

5. In the open window, please change the value to 4.

6. Click "OK" to save the change.

7. Quit Registry Editor and restart the computer.

After that, I recommend downloading Windows XP SP3 from our website in Normal Mode and install it in Safe Mode:

Step 2: Install SP3 in Safe Mode

  PO79 12:42 23 Oct 2008

The advise is correct. For further information and a toll to do the registry hack for you go to click here

  PO79 12:42 23 Oct 2008

toll = tool

  Desperate-Dan 18:03 23 Oct 2008

PO79, the advice Microsoft gave me is not correct,
I followed microsoft's instructions and could not find the intelppm key, so I went to the site you gave me I downloaded the tool and ran it, it did a scan and this is what it said, the Intelppm key does not exist on this computer, thanks for your help

  Fruit Bat /\0/\ 18:22 23 Oct 2008

Your anti virus / antispyware may be blocking access to the registry.

1. Make a backup of your registry.

2. Download and install subinacl.exe.
click here

3. Create a file called reset.cmd with Notepad. Copy the text below into the file reset.cmd and run reset.cmd with administrative rights (it may take a LONG time):

cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

4. Reboot at SAFE MODE and try install SP3 again.

  Desperate-Dan 18:34 24 Oct 2008

I've decided to install the microsoft Service Pack Blocker, I'm not going to gain anything by installing SP3, I've googled till I can't google no more and come to the conclusion I don't need it. thanks to all for your time and help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?