Can't Install Any Mass Storage device or reader

  Hobbit 13:35 10 Apr 2010

I am trying to sort out my mothers computer and it has stumped me. She has a new camewra that will not install as a mass storage so I bought her a card reader. It uses the same driver but it still would not install. It just said no.

I copied the driver from my PC USBSCAN and tried that one because it works on mine. It recognised the camera and the card reader but said that "The service installation section in this inf is invalid"

I think part of the problem is that it is XP SP1 and I have tried on two occasions to install SP2 but the old Mesh machine does not like it.

There must be a way before she has to get a new PC???? Anyone????

  Fruit Bat /\0/\ 13:56 10 Apr 2010

If the camera / pen drive / disk drive is showing up in your Windows' Device Manager under "portable devices" with a yellow "!":

1.) Right-click the yellow "!" and choose "update driver".
2.) When given the option to connect to Windows Update, choose "no, not this time" and click next.
3.) Choose "Install from a specific location (advanced)" and click next.
4.) Choose "Don't search. I will choose the driver to install" and click next.
5.) Click the "Have Disk" button. Browse to C:\Windows\inf and choose the file marked "wpdmtp.inf"

The wpdmtp.inf file might be damaged. It will say the the INF is invalid, go to click here and download a new one and replace the damaged file located in C:\Windows\inf. Relaunch installation, the device is gonna be recognized as a disk. Go to device manager and update the driver. Youre done.

  woodchip 15:07 10 Apr 2010

You can go direct to SP3 and this is what you should be on

  Hobbit 16:14 10 Apr 2010

Sorted. Thanks very much

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?