Can't get Windows Media Player to load or Autoplay

  David0609 15:06 23 Feb 2011

Hi everyone

Hope someone can help, I'm running Vista 64bit version with service pack 2 installed. At some point Windows Media player has stopped working. From the shortcut icon I can't load the player and when clicking on an MP3 file nothing happens. A friend advised me to use a command prompt and type: regsvr32 jscript.dll & regsvr32 vbscript.dll
This I did and everything was OK until I rebooted the machine. Player won't work after a shut down and restart unless I type the above commands in again. Has anyone a permanent solution to this as it is something of a pain having to type these two commands in everytime. Thanks for any help.

  Bris 19:27 23 Feb 2011

Hi David.

The command regsvr32 registers DLLs in the registry. In this case its the Java and Visual Basic script dlls. The fact that you received no error messages when you ran the commands suggests that they ran OK and they cured the problem.
So either something is removing the entries from the registry on bootup, perhaps a virus, or the registry is corrupt.
The first thing to do is to run a full virus scan then try running CCleaner, click on the registry icon and place a tick in the "Applications" box then click the scan for issues and see if it flags any entries relating to Media Player.

Hope this helps.

  Big L 266 19:55 23 Feb 2011


David0609....Your question has intrigued me.I run Vista Home Premium 32 bit and my WMP hasn't worked properly from day one. Every time I opened it up,it had to populate all the tunes from scratch every time taking a good two hours to do it. Once it had loaded it would play,but once it was switched off,it emptied itself and only repopulated itself when opened.

I wonder if you should have a look at the "Autoplay Settings" in the Control Panel.It might be that there is a setting which requires a change. Most of the settings usually say "ask me every time". On the left column under 'Media' there is a sub-heading called 'Audio files'. Can you tell us what the setting is but don't change anything until you let us know what it says in that column.

Big L 266

  David0609 20:28 23 Feb 2011

Disabled 'User account control' and everything seems to work OK. Enable it and problem re-occurs. Also found out that same problem effects Windows Media Centre.

  David0609 21:13 23 Feb 2011

Also see above comment about UAC. Run a full virus scan, no issues found. CC Cleaner reports:- 'Missing Start Up Software' c:\Program Files(x86)Windows Media Player\wmpnscfg.exe

Clicked fix problem, still not working unless UAC is turned off.

Hope someone has the answer. Thanks everyone.

  Bris 18:13 24 Feb 2011

Glad you have at least found a workaround.

A few other things to try are: right click on the Media Player icon then "run as administrator" to see if that works.

The UAC workaround suggests a possible permissions issue, to check, navigate to C:\program files\Windows media player and right click on wmplayer.exe then on properties then security, the user you are logged on as should have read & execute and read permissions. While you are there also check that wmpnscfg.exe is in the same path as wmplayer.exe as CCleaner mentioned it.

  David0609 12:08 25 Feb 2011

Media player will work if 'run administrator' is clicked. Checked wmplayer.exe and read & execute and read permissions are ticked.

  Bris 17:48 25 Feb 2011

David. Can you go back a few steps to cmd.exe (where you ran the regsrv32 commands) but this time run it with elevated privileges i.e. right click on cmd.exe then "run as administrator" then issue the commands again then reboot and see if that makes a difference.

  Bris 18:39 25 Feb 2011

If the above fails then create a shortcut to media player, if you havnt already got one, then right click on it then properties then advanced then tick "run as administrator, that should help when running Media Player from the shortcut but probably not when trying autorun.

  David0609 20:59 25 Feb 2011

Thanks Bris, ran cmd.exe as administrator and media player worked OK within that session. After reboot, smae issue as though there is something wrong with the jscript & vbscript files. Making shortcut properies 'run as administrator solves problem when opening programme from start menu but can't open MP3 file direct by clicking file and same when opening player for on line radio stations.

  Bris 18:43 26 Feb 2011

Hi David.

Can you check ownership of wmplayer.exe by right clicking on it then properties then security then advanced then owner. Owner should be Trusted Installer. You could try changing owner to yourself by clicking on edit then apply but make a note of the changes you make so that you can back track.

I have trawled the Internet on this one but the only fix that seems to work is the script dlls but in your case this only provides a temporary cure. I am struggling to find the correlation between the temporary nature of the fix and the obvious issue with rights and permissions.

I am coming to the conclusion that there is some corruption in the registry but hesitate to suggest a more stringent registry fixer than CCleaner as they often cause more problems than they cure.

This sort of problem stirs the old grey matter a bit. A better brain workout than Sudoku.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)