Can't get out of PIO mode on secondary channel

  Ian in Northampton 13:16 01 Mar 2010

Basic problem is, stuttering playback on audio and video on both my DVD drives.

It turns out, one of three secondary IDE channels is set to PIO mode (it seems XP puts a channel in PIO mode automatically once the channel has had ‘n’ errors), and nothing I’ve done – including uninstalling all three secondary IDE channels and reinstalling them, applying some recommended registry hacks and even a clean XP install – have not fixed the problem.

I’m seriously considering replacing both drives, but I’d rather avoid spending £60 when it could be down to the motherboard IDE controller, the drivers, the cables, the registry – or the drives.

Anyone have any ideas?

  birdface 13:53 01 Mar 2010 is something to look at until you get some help.

click here=

  Ian in Northampton 14:08 01 Mar 2010

Thanks Buteman. Yeah, I seem to have pretty much spent the weekend Googling it. It's amazing how common this problem is, although I'd never heard it before. That's where I got my clues about uninstalling/reinstalling and hacking the registry. The solutions proposed seem to work for many people - but not for me... :-(

  Ian in Northampton 14:09 01 Mar 2010

By the way: ahuge discussion about it can be found here:

click here

  michaelw 14:46 01 Mar 2010

On some pc's there's an enabling facility in the bios.

  Ian in Northampton 14:49 01 Mar 2010

Michael, thanks. Sorry, I should have mentioned - the part of the weekend when I wasn't Googling, uninstalling/reinstalling and registry hacking was spent delving into the BIOS. Couldn't find anything there, though.

  T0SH 15:54 01 Mar 2010

Not sure if it is related but I have come accross PIO only problems with Samsung Spin Point IDE drives
in my case this has happened on a number of Sony Vaio K series laptops

Putting the same Samsung drives in an IBM or Dell laptop they work in DMA modes without problem

On the Vaios using drives from other makers like Hitachi work just fine in DMA modes

Cheers HC

  Ian in Northampton 17:58 01 Mar 2010

Thanks Tosh. I'm not sure if they're Samsung optical drives or not - I'll check next time I reboot. I guess you're talking about hard drives, though, right? The machine in question is a custom-build, built for me by someone else.

  lynette 18:15 01 Mar 2010

Had same problem , this is the answer.
resetdma.vbs just run from desktop.

click here

  Ian in Northampton 20:48 01 Mar 2010

Thanks Lynette. Unfortunately, running this script was one of the things I tried under 'hacking the registry'. I ran the script twice, and then made the changes manually when it didn't work. Glad it worked for you, though!

Anyone else? :-)

  Ian in Northampton 15:41 02 Mar 2010

Absolutely, totally, 100% unashamed bump... :-) (Yep, I'm desperate, and I believe there's someone out there in this very knowledgeable community who might be able to help...)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)