Can't get any sound from computer

  benson68 08:01 20 Aug 2012

My Windows7 computer has lost its sound! The slider control just slips back to zero when I try to increase the sound. In Device Manager, there is the warning exclamation marks next to M'soft 6 to 4 adaptor, ISATAP adaptor & Teredo tunneling adaptor. Should I delete these & restart, hoping that Windows7 will install the correct drivers? I don't want to risk losing anything.

  chub_tor 09:02 20 Aug 2012

The three items with warning marks have nothing to do with your sound problem, they are associated with your broadband network to allow IPv6 connections to be used on IPv4 systems.

Have you any exclamation marks associated with Sound, video and game controllers?

  eedcam 09:26 20 Aug 2012

Apart from the obvious you have not muted it anywhere by any chance.You could Try a system restore

  chub_tor 09:53 20 Aug 2012

This was written about XPbut it might apply to your problem, look at the comments at the end about mic selection.

  Terry Brown 10:11 20 Aug 2012

XP Solution may help you.

From Device Manager, go to the sound devices, right click and select uninstall.

Click on ANY item in the list, go to the TOP and select Action and 'Scan for hardware changes'

This should find your softwatre and re-install the sound drivers.


  benson68 14:52 20 Aug 2012
  • Chub_tor

I think that you've done it! One of the replies mentioned a volume control on the keyboard. I don't use mine, but after clicking it, the slider stayed at max volume. A few days ago though, after a clean-up etc. I got it to stay at max volume then. Next time I switched on, it misbehaved again.

  • Terry Brown

There isn't any mention of "sound devices" in Device manager. Only Sound Video & game Controllers. That's the only mention of "sound".

I'll see how it goes. Thanks Folks.

  benson68 17:24 20 Aug 2012

Nope. Still the same, unfortunately.

  difarn 17:47 20 Aug 2012

You may find a solution in this article about Microsoft 6to4Adapter

  chub_tor 18:33 20 Aug 2012

Did you click on the arrow to the left of Sound, Video & Game Controllers? That should open up another drop down list of your Sound Devices, if nothing is listed there then you have no Sound device installed.

  benson68 09:38 24 Aug 2012

chub_tor Tried that. Only two devices listed, second one is "Via high definition audio." No exclamation mark against it. Sound is working again now. Don't know why!! Maybe Ccleaner has fixed a fault?

difarn I've been informed that I don't need IPv6, & that it's been disabled in "services".

  rdave13 10:47 24 Aug 2012

Another check to do is go to services and scroll down to Windows Audio and check that it's started and on auto, also Windows Audio Endpoint Builder is started and on auto.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)