Can't disable Asus Touchpad

  subi 15:04 16 Apr 2013
Locked

Asus P52F, O.S. 7 Professional. Had problems with hard drive which was replaced and new Windows 7 installed. All Asus references were removed. I use a Microsoft Wheel Mouse Optical instead of the Touchpad. I have found that the pad is so sensitive that when I type emails, word files, etc. that the letters jump about. I have tried to disable the Touchpad via the Mouse settings, also Fn + F9 but nothing works. there is no reference to the Touchpad in Device Manager also, so I can't disable the driver! Help please....this has taken a long time to type as the letters are jumping about!

  Woolwell 15:45 16 Apr 2013

In Device Manager it should be under Mice and other pointing devices.

  Woolwell 15:49 16 Apr 2013

Your manual gives instructions:

Windows - Control Panel - Hardware and Sound - Mouse Click ELAN on the top and check disable when external usb mouse plugged in.

However I do wonder if your problem is associated with the fact that you may not have any of the ASUS software installed.

  subi 19:06 16 Apr 2013

Woolwell....I think you are correct in saying it may be the lack of the Asus software. If I open the Mouse tab it reads Buttons, Pointers, Pointer, Options, Wheel and Hardware. Opening Hardware gives me two entries Microsoft PS/2 Mouse and Microsoft USB Wheel Mouse Optical. No sign of Elan as there should be.

I have checked on some software called Touchfreeze which is supposed to disable the Touchpad while typing. That may be one way of eliminating this problem. Anyone used Touchfreeze?

  Woolwell 20:04 16 Apr 2013

I think that your problem may be because you haven't installed the Elantech Touchpad driver. It can be downloaded from Asus support

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?