Can't connect wirless D-Link DI-624+

  andysmeth 18:32 29 Mar 2006

I have just purchased a Dlink DO-624+ wirless router. I have managed to connect my main pc to the router by wired ethernet and have a cable modem 10mg connection by

I have also got 2 wireless LAN PCI cards 54 mbps which i have installed into two pc's downstairs.

I have followed the manual and set up as infrastructor (without WEP just yet until i can get connected) and they both pick up the SSID from the router which i set in the config pages.
I cannot get a connect at all to the wireless pc's. I'm getting 169ips.

If I set the wireless pc's to ad hoc (which i was advised i have not got that type of network) I do get a green icon saying connected but i get no web pages as it still give a 169ip.

My ISP runs by "obtain everything automatically", so i shouldn't need to assign any static ips???

Can anyone help please?

Many thanks

  mgmcc 20:15 29 Mar 2006

The Wireless Adapters definitely need to work in "Infrastructure" mode ("Ad Hoc" is where the adapters communicate directly with one another and not via a router).

Although the router's SSID is being picked up, have you actually "Connected" to the network? In other words, have you run the wireless adapter's software, scanned for "Available Wireless Networks", found and highlighted the one that matches your router's SSID and selected the option to "Connect" to it? Once "connected", the wireless adapter should get its IP address by DHCP from the router and you should have internet access.

  andysmeth 23:39 29 Mar 2006

Thanks for your reply:-)

The software that came with the adapter seems very basic. It just installs the driver and gives me a utiliy config box I can change settings. Nothing is there for me to run to pick up the network or routers ssid.

I will browse the cd now so see if there is anything. If not, can you suggest anything else?

Appreciate your help, thank you x

  andysmeth 00:05 30 Mar 2006

Ok, I now understand what you mean :-) (sorry for my ignorance, i'm a newbie!)

Yes, in the adapters utility it scans for a network and picks up mine with ssid and which channel it's running on. I click connect to try it and it disconnects automatically. Same for the other wireless pc.

My dad said he had a good signal strenght and connection off my router from his business laptop which is in the same room as one of the wireless pc's, so I just can't figure out why my two pc's wont connect.

Do I need to run any set up within windows or should it just be controlled by the RT2500 ralink adapter software i have?

would it be anything to do with the routers config? I have disabled all security just until i get this connected but also tried to list the mac addresses so only they could connect. It still doesn't work with or without :-(

  mgmcc 08:50 30 Mar 2006

I can't see any logical reason why the laptop's Wireless Adapter should be able to connect, but the PCs don't. Check in the router's wireless settings that it is configured to connect using standard 802.11g 54Mbps protocol, and not the "high speed" mode, if there is such an option.

  andysmeth 16:28 31 Mar 2006

Thanks for your reply:-)

I now have one of the wireless pc's working on the same settings so I think it maybe a signal issue with the other one?

I'm running on a 10mg connection but the wireless pc seems to be running quite slow. Would this be down to the speed of the router?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?