Can't boot from SSD after removing 2nd SSD. Help

  Camblin 21:10 09 Jun 2017
Locked

My PC had 3 storage drives. A 250gb SSD which I'd boot windows from, a 2TB HDD with no windows but which I'd store stuff on, and a 60gb SSD with windows that I'd very rarely use. Upon turning on the PC it'd always give me the choice of the 2 SSDs.

I haven't used the 60gb SSD this year so decided to give it to a friend. We took it out, touched nothing else, but upon turning the PC back on things have gone wrong.

We'd get stuck on the screen with the motherboard logo, have to wait a couple of minutes, to be brought to the bios. From there we've tried to edit the launch sequence but none of it helps.

It recognises all of my drives, and I can attempt to boot from any of them. I pick my 250GB SSD And get the option of 2 windows 7's. Previously the bottom one was to my small SSD, the top one was to my current good SSD.

No matter what we do, it takes us to a page which says "A recent hardware or software change might be the cause". "Boot failed because a required device is inaccessable" I've read posts saying to press F8 before the windows icon appears, but it doesn't work for me.

Also I've tried inputting the w7 installation cd. We used the repair option firstly, but upon restarting the PC did the exact same thing. Now any attempt to repair says "This problem cannot be automatically fixed".

We've tried plugging the SSD back in so that it's EXACTLY as it was before we started, but it doesn't help. I've made sure it's connected correctly and am 99% sure it is, have even changed the cables around to make sure it wasn't them.

If I try to install windows it shows Disk 0 Partition 1: System reserved size 100mb, 67mb free, and then Disk 0 Partition 2: New Volume Size 1.86TB with 33.7gb free, which is my HDD, but my SSD isn't listed there, but is in the bios.

I decided to put windows on my HDD so I can actually use the PC, and I see that the SSD is not displayed on my computer as a device, nor is it shown in device manager, yet it is in the bios.

Sorry for the long post, but does anyone have any ideas? Thanks

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi 8 Review

Adobe confirms it’s working on a full Photoshop for the iPad

Apple announces new MacBook Pros for 2018

Qu’est-ce qu’Amazon Prime ?