Can't access 2nd hard drive.

  bda72 08:27 13 Dec 2005

Hi Guys,

I have 2 maxtor 160Gb hard drives on my machine, I recently did a clean install after swapping them around so the old main drive became the second drive. All worked fine and I copied over most of my files from the old hard drive(god only knows why I didn't copy all of them)and all was good.
I used the old drive for stoving some video files before editing and now when I try to access it all I get is an error message:-

"F:\ is not accessible.

The file or directory is corrupted or unreadable"

The drive appears on the boot screen but if I try anything I get an error i.e. access it with explorer or Partition Magic.

Any ideas for file recovery or is it just stuffed?

Many thanks.


  BigMoFoT 09:25 13 Dec 2005

I have a had a similar issue after swapping drives around and found that changing the drive letter to something that hasn't been used before worked. Also try checking the event viewer logs for anything that might indicate an issue with the drive, filing system etc.

To change the drive letter you need to right click my computer, choose manage and then choose disk management. Right click on the dirve (if it's there!) and choose change drive letters and paths. If that fails check in the event viewer again unders system management and see what it says in there - post back if you need to.

  bda72 09:30 13 Dec 2005

Thanks for the reply, I'm away from home now and will check when I get back, I know it appears in disk management but I can't check it. This problem is new it did not happen at time of clean install on new disk, I was able to access the drive happily for a month or more until last week. Don't know if that points to anything else or not.

Thanks again.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?