Canon smartbase MPC200 - printing probs

  durhampoolie 16:47 07 Dec 2004

Bought new Fujitsu/siemens scaleoP PC. Loaded software for MPC200 (canon multipass) When I connected my MPC2oo via my usb connection I could not print anything. Error message 'unable to communicate with device, check device is switched on and connected' My OS is windows xp home edition. My old PC was a Sony laptop and I didnt have a problem with my MPC200 via the usb connection, this was also windows xp home edition.
Since the problem started i have changed my usb cable to a 2.0, downloaded sp2 but still same problem. Help its been two weeks!

  Mike D 17:26 07 Dec 2004

Search the XP sp2 forum, there is a link to the new canon drivers that you need for sp2


  Mike D 17:27 07 Dec 2004

Search the XP sp2 forum, there is a link to the new canon drivers that you need for sp2


  durhampoolie 18:43 07 Dec 2004

cheers MIKE D but cant seem to find the link you are on about, is it just me being new to PC advisor forum?

  Mike D 22:42 07 Dec 2004

Look in XP SP2 forum for thread with heading something like "Canon SmartBase MPC200 drivers don't work with SP2". I guess it was about October/ early November, but I cannot remember who posted it, but it has a link to Canon Asia site where there are new drivers. As soon as you install them the printer will spring to life (fingers crossed)


  Mike D 22:47 07 Dec 2004

Try this link click here and go onto the support menu and dowload the drivers for Mpc200.


  durhampoolie 18:39 08 Dec 2004

Thanks once again for your help Mike, but it seems the problem hasn't gone away!!! Went to your link to Canon Asia site, downloaded the patch, followed all the instructions but no joy. (Even checked 'about multipass' to check for the 't' identifier to ensure the patch was recognised).Decided to uninstall all the multipass software, reloaded from the begining, downloaded the patch and again no joy. However this time when I went to print there seem to be no error message, but nothing happened. I would appreciate any other suggestions, my hair is wearing thin !!!!!!

  Mike D 08:15 10 Dec 2004


Sorry for the delay in getting back - I've been away from my pc for a couple of days. I'm at a bit of a loss, mine was sorted by the patch. Did you disconnect the printer whilst you reinstalled the software, I know some of these usb thingies dislike being connected before the software is set up. Have you tried contating Canon customer support? Have you tried Control Panel - Performance and Maintenance - Administrative tools - Services - click on MP Service and restart the service (rught click if I remember rightly).


  durhampoolie 18:21 10 Dec 2004

Thanks a lot again for your much needed assistance Mike, I really appreciate it.I found it interesting that the MP SERVICE in my control panel had no status indication, therefore i did what you said to re start it but it came up with an error message -- "could not start Mp Service on local computer, ERROR 1: incorrect function" Sorry for being a bit niave but what is this MP SERVICE and what does this error mean?

  'oppy 21:59 10 Dec 2004

Hello d p, been following this thread, seems there's some conflictions with MS SP2...
Ive searched the web and found this site with some downloads, you may already have them, click on this link to click here
All the best.'oppy (pops)

  Mike D 22:24 10 Dec 2004


MP service is the wotchamacallit that enables XP to call on the printer to do its work (well that's my understanding). As far as the error message is concerned, I really don't know. Have you tried to e-mail Canon? They may be able to help, as might Microsoft. I have used both in the past (the community newsgroups with MS - on the MS Windows site - and Canon's tech support) and have found both to be useful, but you might wait for a couple of days for Canon to get back to you.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?