Canon scanner won't work!

  Calhob 12:48 17 Nov 2003

I'm using XP Home.

I have a Canon LiDE 50 scanner which used to work but doesn't any more. It worked until I restored my HDD from an image file. I have installed the driver and software from the CD that came with the scanner, but no luck.

When I try to do a scan, the scanner makes noises and then tells me to unlock the scanner and disconnect and reconnect the USB cable. Which of course doesn't do any good.

When I open the Control Panel and go to Scanners and Cameras and d/click on the CanoScan LiDE 50 entry and press the Test Scanner or Camera button, the scanner makes noises and then gives the message: "The test failed because the device is not available. Verify the connection and try again". I've tried a different USB cable and have uninstalled and reinstalled the driver several times, without success.

Can anyone kindly give me any advice on how I might get the scanner working again?

Thanks and regards

  Jester2K II 12:50 17 Nov 2003

Have you unlocked it? Check the switch underneath is in the Unlocked position!

  Jester2K II 12:52 17 Nov 2003

If its not locked then test on anther PC. if it still doesn't work sound like a physical failure of the scanner.

  Calhob 12:58 17 Nov 2003

Sorry Jester2K II, I should have mentioned that the scanner IS unlocked. I don't want to think the device has failed, as it's only 3 months old!

  Calhob 13:00 17 Nov 2003

And yes, I've tried it on another machine running Windows ME, also without success.

  Jester2K II 14:17 17 Nov 2003

Scanner is knackered.

  Jester2K II 14:18 17 Nov 2003

3 months - take it back under warranty.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Comment utiliser Live Photos ?