Canon Pixma MG5450 - NT 4.0 Policy: Driver Issue Read more: http://www.techadvisor.co.uk/forums/28/wi

  DaleF 12:49 08 Dec 2012
Locked
Answered

EDIT: Moving this from the Windows 7 Forum as it doesn't seem to fit purpose there :Old Forum Here

Here's my issue I'm having:

I bought a MG5450 2 days ago and began setting it up yesterday however stumbled across an issue where the printer driver would not install regardless of the compatibility setting. Being as it's a newly released printer I thought the drivers would be up to date and new, however I think there may be a issue with NT 4.0 driver policy as when I try to install the drivers through the device manager, it gives me that message that there's a policy in place stopping me.

Windows update always fails when trying to install the printer, however the scanner, and software included all work fine. I can scan images on wirelessly and have them saved on my computer without an issue, however there is no way to print.

I have tried disabling the policing through the 'MSC' and adding a local group policy or something along those lines. However none of this has worked. How can I get the driver to install or disable the policy to allow the printer to be installed.

Running Windows 7 Ultimate 64x

Tried installation of the drivers both through wireless and wired, both come to the same outcome.

Any other information needed, then please ask.

Thanks!

I have tried the following:

No.1 - Tried compatability settings to which they failed and said was no compatible with my operating system

No.2 - Disabled the option 'Disallow for kernel drivers to be installed' I have disabled this in the Registry and another method (Something.msc)

No.3 - I have downloaded Canon's up to date Windows 7 64x drivers from their website, and the drivers still fail

No.4 - Windows update finds the driver find, installs and then fails

No.5 - Tried the 'Add Printer' function and that's where the NT 4.0 message appears.

I am complete stuck and baffled by this issue!

  difarn 19:06 08 Dec 2012

Does your Super Hub have a WPS button? If so it is possible that you can connect your printer wirelessly using that. This link to Canon says that your Printer is WPS compatible.

and this link from Virgin shows you how to do it.

  DaleF 22:33 08 Dec 2012

Difarn,

Thanks for all the help with my situation, I connected the printer to my Hub wirelessly using the WPS method. However, this still never resolved my problem as my computer still needed the drivers for it to be able to be used.

Using my Laptop which runs Windows 7 Professional I was able to install everything fine. I am going to try install my version of Windows Ultimate again on another partition and then try install the printer.

Can anyone confirm if it's still possible to get the release preview of Windows 8? I would like to try that to see if my issue still persists?

  difarn 07:17 09 Dec 2012

Did you try the alternative method offered by Microsoft for installing a non-kernal mode driver?

Microsoft Article

  DaleF 12:30 09 Dec 2012
Answer

Thanks for all the options.

Dr Yes, for some reason the link to download the evaluation just gave me a bad request when I attempted to download. Any reason why it could be down or not installing?

And I have traced the issue down to my own System and version of Windows 7, It seems that somewhere along the way something has gone AWOL and caused the driver to not install properly. Could be down to my previous Kodak Printer which caused many many issues with my system beforehand.

I guess a fresh install or any install of Windows will run the printer properly. Just mine is a little corrupted. I'll try get the download for the evaluation running and see how Windows 8 is like.

Thanks for the support, but the issue was merely down to my own version altogether.

I tested: Another partition with Windows 7 Ultimate 64x, and the printer installed. I also tested it on Windows 7 Professional and it worked also. So, anyone else with this printer shouldn't have any issues.

  difarn 13:51 09 Dec 2012

Glad you have tracked down the possible problem. There are, however, many posters "out there" who are still unable to load the drivers on Windows 7 PC's.

  Woolwell 16:53 09 Dec 2012

Have you tried installing another user (with admin rights) and seeing if the printer installs with that?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Test : les écouteurs Bluetooth Honor xSport AM61