Canon Pixma MG5450 - NT 4.0 Policy: Driver Issue Read more:

  DaleF 12:49 08 Dec 2012

EDIT: Moving this from the Windows 7 Forum as it doesn't seem to fit purpose there :Old Forum Here

Here's my issue I'm having:

I bought a MG5450 2 days ago and began setting it up yesterday however stumbled across an issue where the printer driver would not install regardless of the compatibility setting. Being as it's a newly released printer I thought the drivers would be up to date and new, however I think there may be a issue with NT 4.0 driver policy as when I try to install the drivers through the device manager, it gives me that message that there's a policy in place stopping me.

Windows update always fails when trying to install the printer, however the scanner, and software included all work fine. I can scan images on wirelessly and have them saved on my computer without an issue, however there is no way to print.

I have tried disabling the policing through the 'MSC' and adding a local group policy or something along those lines. However none of this has worked. How can I get the driver to install or disable the policy to allow the printer to be installed.

Running Windows 7 Ultimate 64x

Tried installation of the drivers both through wireless and wired, both come to the same outcome.

Any other information needed, then please ask.


I have tried the following:

No.1 - Tried compatability settings to which they failed and said was no compatible with my operating system

No.2 - Disabled the option 'Disallow for kernel drivers to be installed' I have disabled this in the Registry and another method (Something.msc)

No.3 - I have downloaded Canon's up to date Windows 7 64x drivers from their website, and the drivers still fail

No.4 - Windows update finds the driver find, installs and then fails

No.5 - Tried the 'Add Printer' function and that's where the NT 4.0 message appears.

I am complete stuck and baffled by this issue!

  markd71 14:07 08 Dec 2012

What exactly is your problem ? You bought a new Canon printer and are having trouble installing it on Win 7 ? What has NT 4. got to do with this ?

  Woolwell 14:31 08 Dec 2012

Uninstall printer completely, download latest Canon W7 driver from here and try to install. If that fails then you may well have a problem with your W7 set up.

  DaleF 16:35 08 Dec 2012

All the drivers for the printer install fine, however when it tries to install the printer driver it gives me the incompatibility message saying that 'Kernel-mode drivers cannot be installed due to a NT 4.0 policy on my computer', I've read up and they're disabled as they can cause blue screens etc.

The MP Printer drivers will not install as they are Kernel drivers, and Windows 7 wants User Mode drivers, The link you provided are for the XPS drivers which won't install without the MP drivers.

I will try the installation of the printer on my laptop I have and see if it's my version of Windows or if it's windows altogether.

  Woolwell 17:04 08 Dec 2012

Try this MP driver. I could not find anything that stated that the XPS required MP first but I haven't got a Canon. The drivers are for W7 which does not support kernel drivers so they should be ok. I gather that you have installed in exactly the order that Canon state.

  DaleF 17:05 08 Dec 2012

Yes, that is the policy I had changed to try get the printer to work.

The printer has successfully installed on my Laptop, which is running Windows 7 Professional 64x, I'm guessing somethings up with my system.

Anything that can be done to test or configure this to fix it? I want to avoid a fresh install of everything, to save the hours of hassle?

  DaleF 17:07 08 Dec 2012


That link you provided is broken I may have already downloaded it if it's on the website as I have downloaded most versions released & a message pops up when you install the XPS drivers saying it needs the MP drivers beforehand and then finishes the install at that point.

But my post before kinder changes things to my issue..

  Woolwell 17:10 08 Dec 2012

Regrettably that it seems that Canon may have been right - W7 issue.

  difarn 17:16 08 Dec 2012

I did comment on the old thread. I read a post in which the poster found a solution by installing the printer onto his router - would this be an option?

Another solution, if you have other PC's on your network, may be to install the printer on another non -windows 7 PC and share it through a workgroup.

  DaleF 18:04 08 Dec 2012

I have a Virgin Media SuperHub, so would that be possible to do, I wouldn't mind using it that way as long as it works just as good. I need it for casual printing and scanning?

I'm planning an upgrade to Windows 8 soon, is it still possible to get the preview release to test and see if it would work in that environment of Windows? Might make for an early upgrade that way.

  difarn 18:43 08 Dec 2012

I don't see why this is not possible. I would try it as a wired connection. You should have instructions on how to do this in the operating manual of your printer.

Make sure that the firmware on your router is updated. I know that this doesn't relate to your printer but this post on the Virgin Media forum may help should you have a problem.

What usually happens is that you attach your printer by ethernet cable

On each PC go to Hardware and Devices

Add Printer choose Local Printer but do not Autodetect choose Create a new port and select Standard TCP/IP Port enter the IP address of the printer install drivers either from CD

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)