Canon ip3000 suddenly won't print pictures

  ened 08:53 31 Aug 2013

I am halfway through printing a batch of pictures using this printer and Win7 64. Last night I printed some and went to bed. Turn on machine this morning and it doesn't print. Checked Diagnostics and it repaired a 'Spool' error. It still doesn't print and diagnostics 'cannot find a problem'!

Curiously although it will not print from Explorer, Photoshop or Picasa, it will print Word Documents.

I have been using this printer with Win 7 for some time without problems.

I have tried a System Restore and changed the USB slot. I have removed the printer from Device Manager and let it re-install.

This is an old printer and I am going to buy a new one but I would like to finish this batch today if possible.

  Ian in Northampton 09:55 31 Aug 2013

Is it possible that somehow the default printer for Explorer, Photoshop and Picasa has got corrupted/inadvertently changed? You may want to check which printer is set as the default for those programs. I've had problems in the past where a printer is set as the default printer, but not all programs - e.g. Chrome - see it and keep trying to use a printer that was previously installed.

  ened 10:19 31 Aug 2013

I've checked and I also have a Brother (not very good for photographs)which was my default printer. Although Picasa always defers to the Canon; presumably from memory of previous use. Since this started this morning I have changed the Default printer to the i3000.

This has made no difference. It uses a generic driver so I cannot update that either!

  ened 11:38 31 Aug 2013

I have made some progress, but I don't know if it is relevant? I always use the preview feature so that I have to click on the print button from the preview screen. So far today prior to the preview screen when I have clicked 'Print' on whichever programme I am using the (blank) preview screen has appeared for a milli-second and then disappeared. It has then reappeared a few minutes later but showing no preview.

It is for this reason that I thought it was printing Word documents. This was incorrect because I have just tried printing using Irfanview and I managed to reach the Canon Preview. However as soon as I clicked "Print" it all disappeared and there was no action.

In addition viewing the Devices & Printers the Canon ip3000 is showing as live before I attempt to print but after the attempt it is merely showing up in 'unspecified' labelled 'Category Unknown'.

  Woolwell 12:31 31 Aug 2013

Have you rebooted your computer and switched your printer off and on?

  ened 12:59 31 Aug 2013

I have done restarts and cold boots. I have not only turned the printer on & off I have changed the usb port and even the cable!

When I turn the printer on it settles itself then I get the 'New device connection' sound and all appears to be good.

As soon as I try to print anything I get the above mentioned routine. If I then try to ask the machine to print anything else I immediately get a warning that no printers are connected.

I often tell my aged parent that he needs to remember what happened immediately before an incident like this. But I did nothing. It was printing alright yesterday afternoon and this morning: this situation.

Very Frustrating.

I am going to put some ink in the Brother and see if I can get that to work because I have a funny feeling that all devices connected to printing are going to fail.

  ened 15:33 31 Aug 2013

There's nothing wrong with the printer. I've just plugged it into another machine and it has printed perfectly.

I have done a (several) System Restore. What else can I do to purge this machine?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?