Cannot write temp files after bad shutdown

  User-1322581 17:22 10 Jan 2009

I am running under Windows XP on a Dell desktop. While defragmenting the main C drive I stupidly started up a Solitaire game, which caused the computer to hang. I could not close it down in the correct way, and had to unplug the machine. On restart I can no longer play Solitaire or other games which write temporary files (though email and internet explorer are OK). I get a message saying I don't have access permission to c:\documents and settings\(my name)\local settings\temp. I notice this file, and the ones under it are 'read-only' in properties, but if I change this it goes back to read-only. how do I reset Windows permissions?

A friend said I should re-install Windows, but since that would involve re-installing all my applications as well, I would rather find another way if poss. Please help.

  Fingees 18:16 10 Jan 2009

Have you tried system restore to a point before the problem?

It may just work.

  User-1322581 19:42 10 Jan 2009

Yes, fingees, I have tried but for every restore point I get the message 'your computer cannot be restored to (date)'. I presume this is again to do with permissions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Sam Falconer transforms science and geology into digestible, elegant illustrations

HomePod review

Les meilleures séries Netflix (2018)