Cannot install software

  edennorman 10:52 14 Jun 2005


I have been trying to install the software that comes with my UPS/Anti Power Surge hardware.

Whenever i try I get the following error message:

"Invocation of this java application has caused an invocation target exception, this application will now quit."

When I ask for details this is what I am told:

java.lang.UnsatisfiedLinkError: getSpecialFolderJNI at com.zerog.ia.platform.Sys.getSpecialFolderJNI(Native Method) at com.zerog.ia.platform.Sys.getSpecialFolder(Unknown Source) at ZeroGas.a(Unknown Source) at com.zerog.ia.installer.util.magicfolders.AbstractWin32MF.b(Unknown Source) at com.zerog.ia.installer.util.magicfolders.MagicFolder.initializeAllMagicFolderPaths(Unknown Source) at com.zerog.ia.installer.Main.d(Unknown Source) at com.zerog.ia.installer.Main.c(Unknown Source) at com.zerog.ia.installer.Main.main(Unknown Source) at java.lang.reflect.Method.invoke(Native Method) at com.zerog.lax.LAX.launch(Unknown Source) at com.zerog.lax.LAX.main(Unknown Source)

I have tried contacting the software developers and they said I should turn off my anti virus and firewall, which I did...I also went to task manager and shut down any non essential processes just in case something else was stopping it from installing, but it still gave the same error.

I tried installing it on another PC which is also running Win2000 and it installed fine.

Any suggestions as to what I could try next?

Thank you so much.


  Joe R 11:25 14 Jun 2005


what version of java are you running.?

  edennorman 12:21 14 Jun 2005

What version of Java?? Wasnt even aware that I was running a particular version....thought Java was some kind of script language?

Should warn you this bear has very little brain..


  pk470 12:58 14 Jun 2005

Download JAVA,go to Google to get the website and then try loading your application.

  Joe R 13:21 14 Jun 2005


javascript is widely used as an embedded script, on a lot of websites, and also seems to be the main factor, in the errors you are receiving.

You can download the latest version from here, and see if it helps with your problem.

click here

  edennorman 13:54 14 Jun 2005

Thank you joe R & pk470

Dowloading and installing the latest version of Java has done the trick.


  edennorman 13:54 14 Jun 2005

Thank you joe R & pk470

Dowloading and installing the latest version of Java has done the trick.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Turn a photo into 16-bit pixel art

iMac Pro release date, UK price & specs

Comment suivre le parcours du père Noël ?